SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to Import a master page to Master Page folder from SharePoint designer 2010. Unfortunately it is coming under page Layouts. Not sure what am I doing wrong here? I tried with the import button and drag and drop method nothing working !!

share|improve this question
up vote 1 down vote accepted

When you import or drag and drop any file into the Master Page folder, it will go into the Page Layouts folder by default. If you need to make this appear into the Master Page folder, you will have to go to the portal in browser -> go to Site Settings -> Master page and page layouts gallery -> Check out the file first -> Edit properties of the file -> Make the content type of the file as "Publishing Master Page". This will allow your file to appear in the Master Page folder of SharePoint designer.

Basically the default view of Master Page folder in SPD is filtered with files that have "Master Page" as Content type, and all the rest of the files go to "Page Layouts" folder.

share|improve this answer
Thanks alot Deepu bayya, Thts done :) – Jithu Jan 31 '12 at 6:26
i have the same problem as jithu. I have followed your instructions but failed. The way i did it is that i have imported the master page( that will go to pagelayout folder) from my desktop and then it start appearing in the protal and theni change it by following your instructions. But how can i bring it now from pagelayout to masterpages folder? Thanks – user9205 Jun 29 '12 at 15:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.