Sign up ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have created an InfoPath form workflow in designer. It is a simple workflow which uses the "Collect data from user" task. It requires that the user supply a choice: "Approve" or "Reject", and select a person using a group\people picker.

The workflow executed fine for the first day or so, but now is failing after the first task.

It returns a System\Administrator error to the workflow progress page, but is very under descriptive in the issue.

In the log we found:

Failed to get SPGroupName from GroupID. Error Message: Group cannot be found. Callstack: at Microsoft.SharePoint.SPGroupCollection.GetByID(Int32 id) at Microsoft.SharePoint.WebControls.PeopleEditor.set_SharePointGroupID(Int32 value).

I have run a search for this on the web and have returned a lot of similar results but no solution.

Any Ideas? Similar Situations? Work abounds etc.?

share|improve this question
I also have this issue whenever I open up a custom InfoPath 2010 form running in SP2013. I have 24 contact objects on the form and i get this exact error 24 times whenever I open this form. There is nothing special concerning the contact object. It doesn't reference any odd url and everything in the contact object is default. So what gives? Any ideas? – Patrick Oct 4 '13 at 14:39
Same error here. Complex info Path form with cannot be saved. I'm stuck – elsni Mar 7 '14 at 9:34

3 Answers 3

I had also faced this issue earlier. The form requires multiple approval and I was capturing the different approver inside infopath form. The issue was coming when I was taking the display name of the approver. The issue got away when i tried taking accountId of the approver. Hope this solve ur problem.

share|improve this answer

I think you had this error because of the group/people picker properties are not same on InfoPath and SharePointDesigner. Check both of them and ensure that they are exactly the same. For example, I guess, people picker column in InfoPath allows multiple selection but in SharePointDesigner it does not.

share|improve this answer

I believe the solution is (2) steps: First, in the Group Settings, set the applicable Permission Group (for example: "Can Submit a GCR") to ("Who can view the membership of the group?") to Everyone... Then, republish the form so that the settings are pushed out to the form.

CORRECTION: In my case the form was erroring out because on Form Load I attempt to set a People Picker field to userName() but the column setting for that field was set to a SP Group and that SP group only contained DOMAIN\all domain users. So it was simply not seeing/selecting the individual accounts.

THE SOLUTION: I set the List column to All Users THEN I needed to update the settings on the field in InfoPath manually (it does not update automatically) for each view where the field is used.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.