Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have full control over my SharePoint site. When I click on my document library and then click the "Library" tab on the ribbon, I see an option for "Open with Explorer" but it is disabled.

The message is vague and unhelpful:

You might not have the right permissions level to use this, you might need to select an object or item, or the control might not work in this context.

I want to be able to move documents from one folder in the library to another. This seems like an extremely minimal use-case for a document library, no? Yet it's seemingly impossible to do in the web UI.

UPDATE: I installed IE9 and enabled the WebClient service in services.msc and the Open with Explorer option is still disabled.

share|improve this question
Are you using a version of Internet Explorer? That option would be grayed out with Firefox, Chrome, etc. –  mcnarya Jan 19 '12 at 21:28
What browser are you using? –  Lori Jan 19 '12 at 21:29
I've tried IE8, Chrome, and FF. –  Rob Sobers Jan 20 '12 at 0:56
IE10 was installed automatically as an update. Our IT services company had assured me that IE10 was the best browser for Sharepoint 2010. However, I discovered in the Microsoft documentation, not with Windows 7 . In IE10/Win7 explorer mode just doesn't work. Great. So I uninstalled IE10 and Explorer mode was disabled. Thanks to this thread I was able to start IE9 in 32bit mode and I now have access to my files after nearly an hour of faffing around. Right, now I can get started. Thanks guys! –  user17494 Jun 7 '13 at 7:42
I found this question and solved it today, 04/15/15, by mapping a network drive. Open windows explorer at any path, click the tools menu item and select map network drive. For the path use the browser url used to open the sharepoint site, ending the url with the site folder. Do not include a subfolder or aspx file name. The drive letter can be opened any time just tike any other drive letter and functions exactly the same. –  subjectivist Apr 15 at 21:04

14 Answers 14

up vote 47 down vote accepted

Solved. I was using 64-bit Internet Explorer. Switching to 32-bit IE caused the featured to become enabled. There was absolutely no indication in the application that this could possible be the cause. It was a shot in the dark.

Mind: blown.

The Plan Browser Support article on TechNet lists the supported browsers and limitations in "non- or partially supported browsers".

It states the following among the limitations for 64bit IE 7, 8 and 9:

Explorer view

Removed in SharePoint Foundation 2010. Libraries that have been upgraded from earlier versions of SharePoint Foundation 2010 may still have Explorer views and these may not work.

share|improve this answer
Accept this as the answer please! Had to read the entire thread before I found this (also the same issue) –  Codingo Jan 20 '12 at 2:24
@Michael StackExchange doesn't let you accept your own answer for 2 days. –  Rob Sobers Jan 20 '12 at 4:26
+1 for sharing your solution –  Falak Mahmood Jan 21 '12 at 4:42
+1 - defintely need to keep this in mind. –  James Love Jan 21 '12 at 23:31
hint: SharePoint has the same behaviour in case of datasheet view (datasheet view is only available with 32-bit version) –  DarkTomate Jun 13 '13 at 6:03

Before trying it in IE could you please make sure that following service is started, by going:

Click Start -> Control Panel -> Administrative Tools -> Services

Open the Properties of the WebClient Service

choose as start type: automatic

start the service

share|improve this answer
OK, I just enabled this service. It was stopped and set to "Manual" out of the box. Crazy that this needs to be enabled. However, even after starting it and setting it to "Automatic", the option is still disabled in IE. –  Rob Sobers Jan 20 '12 at 1:00
see my comment placed on the original question about mapping a drive letter to the sharepoint url –  subjectivist Apr 15 at 21:02

Also for me restarting the WebClient service (even though it was running already) fixed it

share|improve this answer

restarting the WebClient service (even though it was running already) fixed this for me

share|improve this answer

Please check this link on how to enable Open With Windows, Upload Multiple Documents options - http://www.indrasani.com/options-greyed-out-in-sharepoint-document-library/

share|improve this answer
I think the .dll copying part is a little extreme. I've never had a user need to do this. On the other hand I've also seen some pretty draconian GP rules that prevent IE from doing a lot of things it really SHOULD be able to do with SharePoint. –  Matt Aug 27 '13 at 18:13

You have to be using Internet Explorer. That option is not available in other browsers. Are you running IE and it's not enabled? If so, what version.

share|improve this answer

Try this available Microsoft Hotfix.

share|improve this answer

Changing to the 32bit version of IE resolved the problem for me. Somehow the IE shortcut in the taskbar had been set to launch IE 64bit and I guess this feature is not compatible with the 64bit version of IE. I changed it back to the normal 32bit version and it started working again.

share|improve this answer

Are you using a version of Internet Explorer? That option would be grayed out with Firefox, Chrome, etc. – mcnarya Jan 19 '12 at 21:28

I had the same problem and this suggestion from mcnarya worked for me! I was trying to open it in Chrome - it works if I open it in IE! May be worth a try.

share|improve this answer

you need to use a 32-bit browser

share|improve this answer

I've had this problem recently with IE 11 x64, I did the following:

  1. Click the settings cog
  2. Click "Compatibility View Settings"
  3. Tick the radio button for "Display intranet sites in Compatibility View"

This then made the "Open with Windows Explorer" option available again in the "Actions" menu.

share|improve this answer

Open with Explorer became enabled when I switched from IE 8 64 bit to IE 8 32 bit.

share|improve this answer

Make sure "Enable Client Integration" is enabled on the web application authentication provider else Explorer View won't be enabled. This is a requirement.

share|improve this answer

Like many of the previous answerers, I have found that using IE 32 bit (any version) to solve this problem. Many of my users all run on different versions of IE or use chrome or firefox (gasp!). Solving this frustrating error always involves either changing the browser or hunting down the 32 bit version or in one instance, adding our sharepoint to trusted sites. Good luck!

share|improve this answer

protected by Eric Alexander Mar 21 '14 at 22:05

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.