Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

For example, if I click Edit page -> Edit in SharePoint Designer from within my SharePoint site, I'm always presented with a dialog prompting me to download Designer. I already have Designer installed.

Seems like it should a.) launch it for me, or b.) at least stop prompting me to download it.

UPDATE: Turns out this stemmed back to the 64-bit IE compatibility issue that was causing me grief here: How do I enable "Open in Explorer"?

share|improve this question
2  
Can't say I've experienced this. Selecting Edit page in SharePoint Designer opens Sharepoint Designer for me. Have you made sure SPD is the default application for editing web pages? –  PirateEric Jan 19 '12 at 21:21
add comment

1 Answer 1

up vote 5 down vote accepted

Switching to 32-bit IE caused this to be a non-issue. I really wish Microsoft would look at the user-agent string and tell the user that stuff is going to be odd/disabled because they're running 64-bit, especially since most machines sold these days are 64-bit.

share|improve this answer
    
I read your answer about 64bit IE, causing the problem with Sharepoint Designer. How do you change to 32 bit, IE, as I have the exact same problem, with Sharepoint Designer 2010, in 64Bit IE? regards, Dan. –  user15207 Feb 28 '13 at 9:37
    
Nice idea. Lets see if I can fiddle this on top of pages as a warning (unless there is already a standard solution somewhere) Probably along : javascript:alert(navigator.userAgent.indexOf("MSIE 8.0") !=-1 && navigator.userAgent.indexOf("x64") !=-1); etc... will do –  edelwater May 17 '13 at 1:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.