Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've created a custom list and added on that list a custom action in the ribbon. Before I created a calendar view on this list, I could see the button in the ribbon, now I can't. Does anyone know what I need to change to see the button in the ribbon again?

Maybe the registrationid is different?

This code was working while I didn't have the new view:

    <CustomAction
   Id="ComposeEmailButton"
   Location="CommandUI.Ribbon"
   RegistrationId="100"
   RegistrationType="List"
   Sequence="5"
   Title="Compose an Email">
    <CommandUIExtension>
      <CommandUIDefinitions>
        <CommandUIDefinition
         Location="Ribbon.ListItem.Share.Controls._children">
          <Button
           Id="Ribbon.ListItem.Share.Controls.ComposeEmail"
           Alt="Compose an Email"
           Command="ComposeEmail"
           Image16by16="/_layouts/images/SENDTO.GIF"
           Image32by32="/_layouts/images/centraladmin_systemsettings_email_32x32.png"
           LabelText="Compose an e-mail"
           TemplateAlias="o1"
           Sequence="30" />
        </CommandUIDefinition>
      </CommandUIDefinitions>
      <CommandUIHandlers>
        <CommandUIHandler 
          Command="ComposeEmail" 
          CommandAction="javascript:..."
          />
      </CommandUIHandlers>
    </CommandUIExtension>
  </CustomAction>
share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Solved it... I redeployed, reactivated the features and it worked. No idea why it didn't work ...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.