Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a WSS 3.0 internet facing site which we have configured to use forms authentication. We have customized the login page to remove the 'remember me' check box. We have problems with users not properly logging out. This web application has Anonymous access enabled.

The problem is this: when logged in to the site using IE 7/8 a user clicks on a document in a document library, the document begins to open, but displays the login page which does not function (I am aware of the update needed to make this work, but this is not the question). If they use Firefox or Chrome and click on the same link, the document opens easily with no login prompt.

Why is this, and can I make IE behave the same as the other browsers?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

The functionality that IE is attempting is actually Office trying to authenticate the user on it's own against SharePoint. Chrome/FireFox doesn't have this level of integration and therefore just opens the document.

You can get around this by disabling Client Integration in central admin (Application Management > Authentication Providers I think, been a while since i've been in WSS3). The big loss here however is that this is a site wide setting, and will disable all users from accessing and updating documents live against SharePoint. They will all have to download and then reupload to update.

HTH

share|improve this answer
1  
This was my experience when we were having login prompts for documents in our SharePoint site. IE was trying to authenticate with Office prior to opening the documents, due to its security settings. –  MichaelF Jan 19 '12 at 18:34
    
Thanks! That's what I ended up doing. They lost the 'Edit in Datasheet', but they'll have to live with out it, or update from Office 2003. –  Lou Jan 19 '12 at 19:53
add comment

Just a thought, I am not sure whether this would work out for Forms authentication, but worth a try.

Can you try going to Tools > Internet Options in Internet Explorer. In the Security tab, select Intranet and click on the button "Custom Level" at the bottom. On the popped up settings page, scroll to the bottom and find User Authentication options. I believe tweaking this option would help you out.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.