Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have been trying to use the Refinement Panel web part to improve the search experience on my site. I've run into an issue where certain taxonomy fields are showing while others are not. This is the XML that I have in my Filter Category Definition:

<Category    Title="Managed Metadata Columns" Description="Managed metadata of the documents"    
             Type="Microsoft.Office.Server.Search.WebControls.TaxonomyFilterGenerator" MetadataThreshold="3"   
             NumberOfFiltersToDisplay="3" MaxNumberOfFilters="20"    ShowMoreLink="True"    
             MappedProperty="ows_MetadataFacetInfo"
             MoreLinkText="show more"    LessLinkText="show fewer" />

But for some reason this only displays one set of taxonomy field filters. I was under the impression that this would include all taxonomy fields that could be used to filter. I also confirmed that there are about 10 documents using the missing taxonomy fields.

Can any one see what I am doing wrong here? Any suggestions where to look to resolve this issue?

share|improve this question
    
How many taxonomy fields are shown? How many should be shown? –  Colin Jan 18 '12 at 17:57
    
Taxonomy fields from one Term Set are being displayed. There are 6 other Term Sets that should have their fields showing. –  Abe Miessler Jan 18 '12 at 18:56
    
Taxonomy fields from 1 term set? do you have fields bound the same term set (anchor terms?) –  Colin Jan 18 '12 at 20:04
add comment

3 Answers

up vote 1 down vote accepted

Are you provisioning Taxonomy Fields yourself? In that case, remember to also provision a Hidden Taxonomy Field, and the TaxCatchAll and TaxCatchAllLabel columns and event receivers (if you are provisioning a list definition with these columns). Outlined in great detail here.

Taxonomy Columns not showing as refiners is a known problem if you skip these steps.

share|improve this answer
add comment

Try increasing the "Number of Categories to Display" refinement web part property value from the default 6. In standard out-of-the-box web part configuration, 5 static categories such as Result Type, Site, Author, Modified Date and Company are displayed which only leaves room for a single taxonomy field.

share|improve this answer
add comment

Another thing to look at is the MetadataThreshold="3" part. If you run you test search and in the results are less than 3 items with that metadata, the category will not be displayed because of that parameter.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.