Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am using List Validation feature for a list which is working fine i.e. doesn't save the item when condition not met. However, it is not showing the error message which helps to rectify the inputs in the column.

Is there a solution to this?

Reply to @ashwnacharya

Thanks!!

Answers to your questions

  1. Choice
  2. =Date-Created_Date>1
  3. I am using Smart List Pro (InfowiseSolutions.com)

Back to point 2 -

When I click on add new item select 15/1/2012 in the column 'First date' (choice column). But since today 16/1/2012 item should not be saved as it does not pass validation rule - So the page reloads but no error message is shown.

From the screenshots you have given, the error which is shown is in red is nowhere to be seen on my list.

share|improve this question
    
Sorry, per the FAQ we do not accept questions about commercial, third-party products. Instead, please ask your question using Infowise's support site: infowisesolutions.com/support.aspx. This question will be closed once the bounty expires. –  Kit Menke Jan 16 '12 at 16:09
    
@KitMenke - I am not facing any issues with third party product and have not asked any related question. I have just replied to question being asked by ashwnacharya - The real issue is with Validation Setting which is an inbuilt feature of SharePoint 2010. –  saumilm Jan 16 '12 at 16:15
    
Ah ok. What is Smart List Pro being used for? It looks like it comes with Column Validation as well? Just trying to understand the question.. –  Kit Menke Jan 16 '12 at 16:17
    
I usually use it for Column Level Permission. However, I think the real issue is that list is unable to post any error when condition is not met for Validation. –  saumilm Jan 16 '12 at 16:20
2  
Is it because of the Smart List Pro? I think you might have tried this. But if not, could you try removing the Smart List Pro and try validation again? or try doing this to a site in the farm where Smart List Pro is not installed. –  Deepu Nair Jan 17 '12 at 8:44

4 Answers 4

up vote 5 down vote accepted
+25

Couple of questions:

  • What column data type are you using?
  • What column validation formula are you using?
  • Just to be sure, are you using the OOTB column validation feature and not some custom validation feature? If so, did you specify the user message property?

I am able to create a simple number column, and set a validation formula as followsenter image description here

And, when I try to set an invalid value to the column, the specified error message shows up as expected. enter image description here

EDIT:

It seems that you are using Date values in a choice column. You cannot use the '-' operator in that case, since the value will be considered a string. Can't you use a date column to store dates instead? Use another calculated column to check the difference in days, and use that calculated column value to set the choice.

share|improve this answer
    
Please read answers to your question above. Thanks!! –  saumilm Jan 16 '12 at 8:40
    
The issue I am facing is why no error message is shown? –  saumilm Jan 17 '12 at 11:33

When you create an item, the creation date is not set so it can't be used in condition.
You can use the current date to do what you want, or a combinaison of the current date and creation date to cover both creation and edit.

share|improve this answer
    
When the condition is not met its an error & hence item is not submitted into the list. That works perfectly well. However, no error is shown only the page is reloaded and due to this user is clueless on what is happening! My problem is that why error is not shown? –  saumilm Jan 16 '12 at 14:21

Do you use branding on the site ? The validation error elements could be affected by custom styles.

Search through the source of your page using developer tools or firebug and see if the message is there.

share|improve this answer
    
No, I am not using any branding. –  saumilm Jan 18 '12 at 4:34

Go to list setting and select the particular column you want to validate. select validation and specify your formula here instead of go to list setting and then to validation setting.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.