Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We are working with a Record Center configured to route documents to different libraries depending on the associated content type.

The rules are created without any particular customization. The only thing is that the Submission Content Type is set to the content type that should go to the list.

The rule in general works perfectly, routing the document to the correct list as soon as its submitted (as it should). But, from time to time an error happens and after submitting the document, instead of the normal message that says that the document was routed to its final destination, this message appears:

The document was submitted successfully. Its location will change pending action from a site administrator. For now, you can continue to access the document here: http://UrlForDocument

I don't know which action should I perform, or if there was an error, what was it and how I can fix it.

share|improve this question

2 Answers 2

I had the same problem and tracked it down to the following 2 reasons:

The item being submitted does not have a content type for which there exists a rule (even though it might get that content type on being added to the destination site, the rule will not trigger (this might also occur when the source site is a different language, that have the same content types that differ in displayname)

A user field in the item submitted contains a non resolvable user (think domain trusts)

CHeck the logs, because when this happens, the webservice sharepoint uses to submit files will log a MoreInformation and tell you what went wrong (which is not very specific, but might for instance say missing props (= fields))

share|improve this answer
up vote 0 down vote accepted

Just posting the "solution" to my problem.

We discovered that the issue was that there were some fields that were failing validation. Sharepoint saved the changes but for some reason (still unknown) the item remained unrouted.

After the user fixed the invalid fields, everything worked out fine

share|improve this answer
    
Kiranu (above) is correct. For example, content type of "Pictures" requires a title before it will redirect the picture to the correct folder but this is not required for content type "document." –  user8253 May 8 '12 at 20:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.