Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have issues with Office Web apps. After some logging search I found it's because of the service account of owa service application does not have access to the content DB.

I've read somewhere that the service account has to be member of db_owner role on the content databases, which is not the case for me.

The documentation states :

After you run the configuration wizards, SQL Server and database permissions include:

  • Dbcreator fixed server role.

  • Securityadmin fixed server role.

  • db_owner for all SharePoint Server 2010 databases.

  • Membership in the WSS_CONTENT_APPLICATION_POOLS role for the SharePoint Server 2010 server farm configuration database.

  • Membership in the WSS_CONTENT_APPLICATION_POOLS role for the SharePoint Server 2010 SharePoint_Admin content database.

The WSS_CONTENT_APPLICATION_POOLS seems to be created only for some database, not for front apps content databases.

I have created a dedicated application pool, with a dedicated managed account. What is the correct way to grant access to all content DB for this user ?

Have I to manually set up the permissions in all content DB ?

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

The easiest way I have found is to use the [SPWebApplication.GrantAccessToProcessIdentity][1] method. It grants the specified user account access to the process identity and provides full control of the SharePoint Web Application. Office Web Apps can use this to access the content databases as the SharePoint Web Application's process identity, which already has access to the content databases.

You can do this with the following PowerShell:

$webApp = Get-SPWebApplication http://my.webapplication.com
$webApp.GrantAccessToProcessIdentity("domain\username")

[1]: http://msdn.microsoft.com/en-us/library/ms478270.aspx - notice that unfortunately, the description of this method on MSDN is incorrect.

share|improve this answer
    
thanks for the tip. Here is the lazy version : Get-SPWebApplication | % { $_.GrantAccessToProcessIdentity("domain\username") }. Even if it's not fully automated, it's still better than a manual Sql modification. Thanks –  Steve B Jan 12 '12 at 10:38
    
I ran this powershell command but I am still getting this error: Word Web App cannot open this document for viewing because of an unexpected error. To view this document, open it in Microsoft Word. We have another web application that opens docs successfully on this same farm. We created this new web application but we are unable to open documents. the office web application feature is enabled on the site collection. –  user14042 Mar 1 '13 at 18:11
    
How do you set the WSS_CONTENT_APPLICATION_POOL using this since its not a domain user, I've seen GUIDless Admin Content DBs end up without that user having a role and this looks like it might be a good option to grant it though without a domain I am not sure it will work. –  MichaelF May 2 '13 at 18:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.