Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Using SharePoint Foundation.... I installed the Win Server 08 R2 language packs and SharePoint Foundation Beta language packs. I changed my english language to Spanish on the SharePoint site and now i get "Unexpected Error" on all sharepoint pages.

Anyone know how to resolve this?

Thank you in advance.

share|improve this question

4 Answers 4

I fixed the site by logging in with a different admin account, going to site actions > site sttings > language settings > unchecked Spanish and clicked OK.

This does not solve the functionality issue of being able to change a site's language on the fly however.

Any follow up is appreciated.

share|improve this answer
    
I also get the same error creating a new sub site in Spanish... –  Anonymous May 5 '10 at 16:19
    
I assume you have a good reason, but why mess around with the potentially flakey beta when the RTM version is available? –  Muhimbi May 5 '10 at 17:00
    
Beta language packs are the only language packs available at the moment. We're using the RTM Foundation bits –  Anonymous May 5 '10 at 17:08

I get the same error on RTM and Russian LP for Sharepoint Foundation... You can open site without using another account - just clean cookies in IE.

share|improve this answer
up vote 0 down vote accepted

Microsoft released the RTM Language packs about a week ago and I have not had any issues since.

Language packs for SharePoint 2010 download

share|improve this answer

Server Product Version Install Status RA-IIS01 Microsoft SharePoint Foundation 2010 Installed RA-IIS01 Microsoft SharePoint Foundation 2010 14.0.4763.1000 Installed RA-IIS01 Microsoft SharePoint Foundation 2010 1033 Lang Pack 14.0.4763.1000 Installed RA-IIS01 Microsoft SharePoint Foundation 2010 Core 14.0.4763.1000 Installed RA-IIS01 SharePoint Foundation 2010 Language Pack - Russian/русский Installed RA-IIS01 Microsoft SharePoint Foundation 2010 1049 Lang Pack 14.0.4536.1000 Installed RA-IIS01 Microsoft SharePoint Foundation 2010 1049 Lang Pack Core 14.0.4536.1000 Installed

We are using RTM as you can see. RTM Language pack released more 2 weeks ago...

share|improve this answer
    
Does anybody know how to get not localized error from .Net? My site generate errors in russian language, but I want see it in english. –  Anonymous May 27 '10 at 18:07
    
Look's fun, but sharkmu25 rights! I've try download LP again and get newer version. After installing it error has been gone. Final version of LP is 14.0.4763.1000, look's like MS upload wrong version in first days. –  Anonymous May 28 '10 at 13:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.