Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've installed SharePoint 2010 Foundation on Windows 7 based on this article. When I do a search in one of the team sites I've setup, I received this error The search request was unable to connect to the Search Service. When I go to the Central Administration -> Manage Service Application this is what I saw Manage Service Application

As you can see there is no SharePoint Foundation Search running. How do I add the SharePoint Foundation Search Service. Thanks. Really appreciate any help.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

My teammate found the answer, this is how to solve it. Open SharePoint 2010 Management Shell and run this script

PSConfig.exe -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures

Now go to the Central Administration -> Manage Services on Server and you'll find that the SharePoint Foundation Search is running.

Hope this helps.

share|improve this answer

I have absolutely no idea why is it as it is, but I managed to solve the same problem by .... entering SharePoint Foundation Help Search....

Basically when you click to stop Help Search, the option SharePoint Foundation Search is back but the Help Search is gone... Start it again and the options switch back to as they were... Just as if the labels were changing for some reason I can't comprehend

share|improve this answer

Not that familiar with SharePoint foundation but the search service application might need to be provisioned first?

share|improve this answer
    
thanks for the effort, but I'm looking for SharePoint Foundation Search and not SharePoint Search Service –  Agamand The True Jan 11 '12 at 2:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.