Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

The alerts are working, but for some reason the " Send e-mail when ownership is assigned" on a task list is not working.

A task is assigned to a user however Immediate-alerts are not sending the emails. I tried with the below commands

stsadm -o updatealerttemplates -url http://testserver -f "c:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\XML\alerttemplates.xml" -LCID 2057

stsadm -o setproperty -pn job-immediate-alerts -pv "Every 2 minutes between 0 and 59" -url http://hulmossteam:25000

also, turned off and turned on the "Send e-mail when ownership is assigned? " setting but still not able to fix the issue.

any thoughts ?

Update:
Deleted the existing Tasks list and created a new Tasks List still it is not working...

I could see the below entries are in the "dbo.ImmedSubscriptions" Table against that site-collection

UserEmail=
ListURL = Lists/Tasks
AlertTitle = System
AlertType = 536870912
AlertTemplateName = SPAlertTemplateType.AssignedToNotification

I have restarted the Timer job but still no luck, subscription emails are working so I guess SMTP is configured correctly.

I did not do an IISRESET, is that mandatory ?

share|improve this question
1  
--It is working perfectly for another site-collection but not for this site-collection ? – Karthikeyan May 6 '10 at 1:27 Did you figure out how to get it to work on the other site-collection? I'm having the same problem, works on one but not the other. Thanks Kim –  kim Feb 12 '13 at 14:37

4 Answers 4

The first thing to realize is that SharePoint has basically two methods of sending emails

a) In response to an event on a page load/postback - such as

  • The Alert Me confirmation message or

  • Assigning a task (the one you are missing)

  • Adding someone to a site.

b) From the the SharePoint timer service which includes all the Alert Me type emails including the "Immediate" one (its not really immediate, its every 2 minutes by default.)

Your missing emails are coming from a) and not b) - so I don't think mucking around with the alerttemplates.xml file or the job-immediate-alerts setting is going to help.

The first things to discount

  • SPAM filters

  • Incorrect email addresses in the person you're assigning a task to (don't assume because its right in AD its right in SharePoint - click on the name in the task list and verify)

Then I would check are you getting the "Alert Me Confirmation" emails when you sign that same person up to an alert.

If you DON'T get that then I would look at anti-virus blocking smtp emails from the W3P worker process (the timer service runs in a different process).

If you do then gawd only knows - time for Microsoft PS?

I've put together a troubleshooting guide for SharePoint Alerts - but I don't think its going to help much in your case.

share|improve this answer
    
It is sending the mail messages while adding someone to a site and for Alert Me. Issue is just with the Task List, it is not sending the emails. Email addresses are correct. between, can you please let me know the usage of "Immediate" alerts (Section-B) and when it will be triggered ? –  Karthikeyan May 5 '10 at 21:42
    
It is working perfectly for another site-collection but not for this site-collection ? –  Karthikeyan May 6 '10 at 1:27
up vote 3 down vote accepted

Checked the timerlock table on the content database and it was running on the Inactive SharePoint Server. so, Stopped the Timer service temporarily on that server which moved the timerlock to the active Server.

Steps to resolve the issue:

  • Make sure you have SharePoint already configured for outgoing emails.
  • Make sure that you have alerts for the document library turned on if you are testing with the document library.
  • Run this command from C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN: stsadm -o updatealerttemplates -filename "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\TEMPLATE\XML\customalerttemplates.xml" -url
  • Run this command: stsadm -o setproperty -pn job-immediate-alerts -pv "every 1 minutes"
  • Run this command from the command prompt: iisreset
  • Run this command from the command prompt: services.msc
  • From the services window, restart the Windows SharePoint Services Timer.
share|improve this answer
    
As you're mostly on the command line here, why use services.msc and not "net stop" / "net start"? –  Alexey Krasheninnikov Aug 22 at 8:30

Use:

stsadm -o updatealert -url [current url] -oldurl [old url]

It will update Siteurl column in Immedsubscription table and maybe something else

You need to update your stsadm : http://www.microsoft.com/en-us/download/details.aspx?id=4388

share|improve this answer

the main point that fix my problem which occured after moving to new farm was the following

  1. Is your Exchange server allows SharePoint to Send Mails? In Exchange Server, If anonymous Relay settings is not enabled, then you must add your WFEs in the relay list.? M**ake sure your ALL Sharepoint WFE'**s IPs are added in allowed Relays or Receive connectors in Exchange Server. If you use multiple domains, add all of them. http://technet.microsoft.com/en-us/library/cc288949.aspx Watch the 'DROP' folder in the mailroot of the SMTP server.

Read more: http://www.sharepointdiary.com/2012/02/sharepoint-alerts-not-working-troubleshooting-checklist.html#ixzz3C3jbADd3

adding all the servers (except database servers) in the Exchange relay list fix the problem

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.