SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a SharePoint 2010 Enterprise installation with the Dec 2011 cumulative hotfix. It is using integrated authentication and is on SSL. I can access my site collection from outside the server in the browser and everything works fine.

When I try to publish an InfoPath form template to my site, InfoPath gives the error "The following web server does not appear to be running SharePoint: {same url that opens fine in the browser}."

When I try to open the site in SharePoint designer (from outside the server itself but also from a location where the site opens in the browser), I get the error "The server at '{same url that opens fine in the browser}' does not appear to have Microsoft SharePoint Foundation installed." I have client integration enabled on my web application for Windows authentication (the app is not extended).

Since these two messages are similar I assume they are caused by the same thing. Does anyone know what this might be?

share|improve this question

Is there a site collection created at the web application root? SP Designer and InfoPath have problems accessing and publishing if a web app root site collection is not created.

For example: publishing to without a site collection at would cause the error youre seeing to occur.

share|improve this answer
Yes the one and only collection is at the root. – J T Jan 12 '12 at 14:10

It sounds like Client Integration is turned off for this web application. Goto Central Administration > Application Management > Manage web applications. Select the Web Application and click Authenication Providers on the ribbon. Select default (or whatever provider you are using) and make sure "Enable Client Integration" is set to yes.

share|improve this answer
Client integration is already on :( – J T Jan 10 '12 at 2:01

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.