Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've built a workflow in VS. The wf contains a 'Create Task' and assigned to a group. When I run the wf an email is recieved and all works.

I then added a 'send email' actitivity and used the following parameters in the code block :

SendEmailResponse.To = "Credit Approvers";

SendEmailResponse.From = @"somecompany\itmanager";

SendEmailResponse.Subject = "Expense Report Approved";

SendEmailResponse.Body = "Your Expense Report: "; 

Now when I run I always get an error :

The e-mail message cannot be sent. Make sure the outgoing e-mail settings for the server are configured correctly.

I've also tried specific email addresses rather than groups but continue to get this message. I've tried various corelation tokens also.

If I get the email through ' create task' then could a problem still exist with the out-going email settings as in the error message?

share|improve this question
add comment

1 Answer

I have generally observed that when Task emails work, the emails configuration is fine but there could be an issue with sending emails to a SharePoint Group.

As far as sending emails to SharePoint group is concerned, I had similar question and I ended up writing a custom activity which outputs email addresses of group members in an output variable: Definitive answer to sending emails to SP Group from Workflow

share|improve this answer
    
Hi I've also tried individuals also, this doesn’t work either. –  Raj Chahal Jan 9 '12 at 8:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.