Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am testing SharePoint 2010 foundation with bcs to access one of my sql tables. I created a list with filters on some fields (wildcard and limit types)

But unfortunately, when I display (browser) the list no selection fields appear Do you know why? Is it because of I'm using foundation?

share|improve this question
    
what do you mean, "selection fields"? –  Derek Gusoff Jun 17 '12 at 3:09
add comment

3 Answers 3

You need to set default values on your wildcard filters. When you set up filters on a BCS Read List operation, the list will show whatever the default value of the filters allow.

Do do this, when you are setting up the filter, you'll see a text box for "Default Value". Enter a value in there and update the ECT, and you should be all set.

share|improve this answer
add comment

are you getting any error messages? here is a post with some BCS related errors & fixes - http://www.chakkaradeep.com/post/Part-2-BCS-Connectivity-Errors.aspx

share|improve this answer
add comment

BCS works flawlessly on SharePoint foundation. I have imported an SQL Azure table as a external list and tested it for basic CRUD operations. Can you give more details about your error?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.