Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Using SharePoint Designer, I am trying to create some dummy listforms (newform1,editform1 or displayform1) but when I create one it pops up the following error.

"could not save the list changes to the server"

and even when I try to edit the existing list form lets say the newform.aspx and try to insert the SharePoint control "custom list form" it does not get drop in the form.

share|improve this question
    
Hi! How about logs? Where are may be some meaningful rows. In additional, it may be permissions problem. –  IAfanasov Jan 5 '12 at 7:44
    
Have you considered customizing with InfoPath? –  Lori Jan 6 '12 at 14:38
    
I have to say I had this problem and confirm that PirateErics Solution solved my problem. Great Job. Thanks. Was initially very worried I have to say as list was huge. –  user11470 Oct 19 '12 at 9:38

3 Answers 3

up vote 2 down vote accepted

I came across a solution which suggested to check for broken lookup columns in the list and went ahead and deleted the broken lookup columns (which were looking up data which was not there) and then it let me to add the forms.

share|improve this answer
    
do not forget to refresh Sharepoint designer for getting new Metadata after removing invalid columns –  imanabidi Jun 26 at 8:26

Actually I found that issue started to appear when i tried to add field or new edit/display form to existing one, if there ware some documents in the library that were checked out or reserved by other people. When i deleted all the items (documents) or undone their reservation i was able to add edit/display forms again.

share|improve this answer

Solution for Sharepoint 2013... For me, I also had this problem...

Connect Problem

To see if you also have the same problem as me run the following powershell..

(Get-SpWeb https://url).ListTemplates | ? {$_.Name -eq $null }

Then if you get something with the guid "e374875e-06b6-11e0-b0fa-57f5dfd72085"

Disable-SPFeature -Identity "e374875e-06b6-11e0-b0fa-57f5dfd72085" -Url http://sitecollectionurl

will fix it. I had to delete my webcache in C:\Users\UserName\AppData\Local\Microsoft\WebsiteCache and reopen Sharepoint designer before designer would let me create the form though.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.