Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We upgraded our MOSS 2007 to SharePoint 2010 yesterday. Everything seemed fine until I chose Show Ribbon from the site menu.

Now I get an error like this: "One or more field types are not installed properly. Go to the list settings page to delete these fields"

And there is some more detail related to this error in ULS:

System.Runtime.InteropServices.COMException: One or more field types are not installed properly. Go to the list settings page to delete these fields. at Microsoft.SharePoint.Library.SPRequestInternalClass.GetListItemDataWithCallback2(IListItemSqlClient pSqlClient, String bstrUrl, String bstrListName, String bstrViewName, String bstrViewXml, SAFEARRAYFLAGS fSafeArrayFlags, ISP2DSafeArrayWriter pSACallback, ISPDataCallback pPagingCallback, ISPDataCallback pPagingPrevCallback, ISPDataCallback pFilterLinkCallback, ISPDataCallback pSchemaCallback, ISPDataCallback pRowCountCallback, Boolean& pbMaximalView) at Microsoft.SharePoint.Library.SPRequest.GetListItemDataWithCallback2(IListItemSqlClient pSqlClient, String bstrUrl, String bstrListName, String bstrViewName, String bstrViewXm... d2c112c4-8af3-4d76-8aab-dc1a9d58468b

Any ideas?

UPDATE: I think this is something about publishing infrastructure, because I get the same error when I try to navigate to Manage Content and Structure page.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.