Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I see it is possible using code, but this is not an option for us at this time as it is not supported.

<style>

 .ms-ButtonHeightWidth
 {
 display:none;
 }

</style>

I use SPD2010. thanks

share|improve this question
    
what do u mean by adding code? the above style can be added into the css and applied to the master page. –  Deepu Nair Jan 3 '12 at 6:59
    
I want remove the close button . I found this link qa.social.msdn.microsoft.com/Forums/en-US/sharepoint2010general/… –  ar.gorgin Jan 3 '12 at 7:06

1 Answer 1

I saw the link provided and the post suggests to add the style in a web part for the disp form.aspx. That would be the best approach since you can hide the button for just one disp form in a particular list. Otherwise, if you add the style in your custom css the button would be hidden on all the lists throughout the site.

There is one more option that you could try out for the particular list.

  1. Open the site in SPD and go to the folder Lists.
  2. Right click on the particular list that you want to modify and click on Properties.
  3. On the opened List settings screen in SPD, you would be able to add a custom Form, by clicking on New on the right hand side.
  4. Enter file name and Select Display Item form and set this as default.
  5. On the newly created Form, right click and edit in Advanced mode.
  6. Inside the PlaceHolderBodyAreaClass add the style .ms-ButtonHeightWidth { display:none; } and that should fix it.

Good Luck

share|improve this answer
    
Thanks , but Does not allow to add new code in PlaceHolderBodyAreaClass –  ar.gorgin Jan 3 '12 at 9:57
    
Add it like this - <asp:Content ContentPlaceHolderId="PlaceHolderBodyAreaClass" runat="server"> <style type="text/css"> .ms-ButtonHeightWidth { display:none; } </style> </asp:Content> –  Deepu Nair Jan 3 '12 at 9:59
    
thanks.but when i use this code , i get error ( Web Part Error: Unknown server tag.) –  ar.gorgin Jan 3 '12 at 14:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.