Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Environment: SharePoint 2010 on Windows 2008 R2 Standard + SQL Server 2008 R2, Dashboard Designer

I was successfully able to add a standard SQL Table as a data source and create a Scorecard Dashboard out of it. That works fine. My next attempt was to create a Pie Chart. For this, a multidimensional Analysis Services data source is required. I tried to setup a cube on the same SQL server from where I got the plain table. This is the article I followed: http://www.packtpub.com/article/creating-analysis-services-cube-visual-studio-2008-part2

Looks like the cube was setup fine! However, when trying to connect to this Analysis Services data source from the Dashboard Designer, the dropdown list for Database field is empty. Could it be because of the missing permission? But then it is the same user ... Do I need to do anything to "publish" the cube?

Any troubleshooting hints, either for the SQL Server or the SharePoint server ?

Thanks!

share|improve this question
    
even i am facing the same problem.it is showing me database but not showing me cube.can u just explain me how did yo resolve it.because i tried as you told.i mean to say creating role and then did u give that role is dashboard desginer? –  harshi Jul 13 at 16:17
add comment

1 Answer 1

up vote 0 down vote accepted

Figured it out myself after fiddling with it for some more time: you'll have to add required Role(s) on the SQL Analysis Server. Go to Databases -> Roles -> New Role .. and give the necessary permissions.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.