Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am trying to create a new page by going to "Site Actions/new page" first it gives me a little modal page which contains two buttons Create and Cancel and following message:

In order to create wiki pages on this site, there must be a default wiki page library and a site assets library. Would you like to create those document libraries now?

When I click on Create button it generates a new modal which says:

Error A list, survey, discussion board, or document library with the specified title already exists in this Web site. Please choose another title.

I haven't chosen or entered any title. Appreciate any kind of advice.

share|improve this question

migrated from stackoverflow.com Dec 29 '11 at 13:27

This question came from our site for professional and enthusiast programmers.

    
What site template did you use? Are there currently any lists called 'Site Pages' or 'Site Assets'? –  Nigel Whatling Dec 29 '11 at 11:55
    
"New page" link in Site action menu generates same error (above) regardless where I am and regardless which webtemplate I have used. most of my webtemplate are based on STS. BaseTemplateName="STS" BaseTemplateID="1" –  Medes Dec 30 '11 at 10:08
add comment

1 Answer 1

I would view all site content and see if you have an existing Site Pages and Site Assets libraries. It sounds like either, the site had publishing turned on at some point and then that was turned off or the publishing features were not fully provisioned when they were turned on. If you have the "Site Pages" and "Site Assets" try either renaming them or deleting them (if you have nothing in them) and then creating your new page.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.