Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a farm where for every new site collection the "Open Documents in Client Applications by Default" feature is disabled. So when ever a user opens an excel or word file it will try and open it in the browser instead of the client application. As the Office web applications are not installed (and as far as i'm aware have never been) it throws up an error in the browser:

Unable to process the request.

Wait a few minutes and try performing this operation again.

So far I have been enabling the "Open Documents in Client Applications" on a site collection straight after creating it but how can I enable it by default for any new site collection that I create?

share|improve this question
    
Can you post the associated ULS entries when this happens? –  Jesus Shelby Apr 28 at 1:16

2 Answers 2

You should be able accomplish this using Feature Stapling. Create a feature with Scope as Farm. Then staple it with the site definition template id with which the new sites are getting created. Then activate the required feature for that site definition. Once your feature is activated in Farm, any new site created on the specified site template will have your feature activated.

Here is a post that speaks about a similar scenario of activating features -

http://blogs.msdn.com/b/sowmyancs/archive/2009/09/25/feature-stapler-for-mysite-to-activate-the-publishing-infrastructure-feature.aspx

share|improve this answer
    
I am very hesitant to create a work around for this problem, I would rather address the core issue. Do you have any ideas as to what is causing it? I have a feeling that it is not the default behavior. –  Rkaede Jan 3 '12 at 5:38
    
Different features in a site collection are activated, based on the template that you select for that site. For eg-, when you select a collaboration portal template, you have publishing feature enabled by default and if its a blank template, most of the features are disabled. So, if you still need this, you might have to create your own custom site definition with this feature enabled. Good Luck! –  Deepu Nair Jan 3 '12 at 17:29

In central admin, turn off the 'Word Automation Services' and 'Excel Services' under System Settings > Services on Server

share|improve this answer
    
I can confirm that those 2 services are not enabled on any server in the farm and the problem persists. –  Rkaede Jan 3 '12 at 5:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.