Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

The desire is to remove the "All site content" link from the quick launch menu on all sites.

I have removed it from our master page. However when I now go to a site that has been created using a blog site template, the link is back!

Has anyone experienced this before and how can I handle this issue?

edit

I have deleted the following section from the masterpage :

<li>
                            <!-- For normal settings replace the permissionstring with the original: PermissionsString="ViewFormPages"-->
                            <SharePoint:ClusteredSPLinkButton
                                id="idNavLinkViewAllV4"
                                runat="server"                                  
                                PermissionsString="ManageWeb"
                                NavigateUrl="~site/_layouts/viewlsts.aspx"
                                ImageClass="s4-specialNavIcon"
                                ImageUrl="/_layouts/images/fgimg.png"
                                ImageWidth=16
                                ImageHeight=16
                                OffsetX=0
                                OffsetY=0
                                Text="<%$Resources:wss,quiklnch_allcontent_short%>"
                                accesskey="<%$Resources:wss,quiklnch_allcontent_AK%>"/>
                        </li>

But the "All site content" button is still visible on sites using the Blog site template.

I mean this button:

enter image description here

share|improve this question
    
Do you use different masterpages? –  Daniel Ziga Dec 28 '11 at 11:45
    
I Use a custom master page as both the system master page as the front facing master page. I Edited this like in my post to hide the all site content button, however in the blog sites it is still showing, in all other sites it's gone as it is supposed to. –  nldev Dec 28 '11 at 13:32

3 Answers 3

I don't think you need to remove sections from your master page to hide 'View all site content'.

It can be hidden using any of the methods:

  1. PermissionsString in the ClusteredSPLinkButton for your site is currently 'ManageWeb'. This means that possibly only site collection admins can see the link in your site. PermissionsString property controls the security of the control. You can decide to display the link to certain group of people while hiding it for the others.

  2. You can give an additional parameter of 'Visible="False"' inside the ClusteredSPLinkButton. This should probably hide the control for all.

  3. You can also simply add css style to hide the whole quick launch control or just the 'View All site content'.

    <style> #ct100_PlaceHolderLeftNavBar_idNavLinkViewAll { Visiblity:hidden; }

    /* for entire QuickLaunch */

    .ms-navframe{display:none;} </style>

share|improve this answer
    
I tried the first method, this works just not for the blog site. The second method also works but also, not for the blog site. –  nldev Jan 2 '12 at 15:10
    
Thanks. The second method also works but also, not for the blog site.When i tried the third method, the all site content item was still there, i copied your text to my css ( added the i in visibility ) But it was still there, any other ideas? I am geussing something in the blog page is overriding my settings... –  nldev Jan 2 '12 at 15:16
    
Is your css running after the corev4.css? You should run your css in the master page using the "after=corev4.css" tag, otherwise the corev4.css will override your styles. If its still not working, could you paste the html, that is rendered for the blog site, just containing the Quick Launch part. –  Deepu Nair Jan 2 '12 at 17:31

On a blog post on my blog site, I have a post mentioning using jquery to hide that link here is a link post that explains how to do this. I hope you will find it helpful.

http://spcrew.com/blogs/Lists/Posts/Post.aspx?ID=23

Basically, use jquery to find the link text relative to the html tag and hide it.

thanks

share|improve this answer
1  
Firstly, we require relevant answers and disclosure of any affiliation with products or websites. Please see May I promote products or websites I am affiliated with here? for guidelines. Secondly, we prefer the detail of the answer here, with the link provided for reference. Thanks. –  SPDoctor May 15 '12 at 11:07

You must change your system masterpage, not your site masterpage. But, be careful that this will cause potential headache in the future.

First, enable the publishing feature on that site, under site action->site setting->site feature. Now you can change your system and site masterpage under site action -> site setting->masterpage.

change master

share|improve this answer
    
I have changed both the masterpage as the system masterpage to use my new master page. I edited my question so it contains extra information regarding the question. –  nldev Dec 28 '11 at 12:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.