Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a situation where users recieve the following error when trying to view a library/list in Explorer Mode:

Your client does not support opening this list with Windows Explorer.

We have tried everything from the regedits, switching from Trusted Sites to Intranet, Hotfixes and restarting the webclient. We have experienced this issue in all combinations of Windows Vista, XP, IE 7, IE 8 and IE 9.

However, if the user installs SharePoint designer 2010 and connects to the site one time, windows explorer mode will work.

Environment:

Windows 2008 R2 SharePoint 2010 SP1 Claims Based Authentication using ADFS as custom provider
Port 443

share|improve this question
    
I can remember that enabling the WebClient service on the client computer could probably help... but I'am not sure... –  Matthias Dec 22 '11 at 14:20
add comment

3 Answers

To successfully make “Open with Explorer” work, we need to ensure the following:

1) WebClient service is started: WebClient service which the WebDav protocol enables Windows-based programs such as Windows Explorer to create, access and modify Internet-based files.

Important Note: If you are running a server type Windows OS, for example, you use Window Server 2008, install Desktop Experience feature first to get WebClient service installed.

a. From the Start menu, point to Administrative Tools, and click Services.

b. Scroll down, right-click WebClient, and click Properties.

c. In the Startup type list box, click Automatic.

d. Click Apply.

e. In the Service status section, click Start.

f. Click OK.

2) You have supported Web browser: For a list of supported Web browsers and support level information, please visit: Plan browser support From the page you can see it’s recommended to use 32-bit Internet Explorer 7,8,9. Note: “Open with Explorer” may not work if you have 64-bit Internet Explorer and 64-bit Microsoft Office installed.

3) Add https://*yourSharepointSite to Local intranet site: To configure Web browser, open “Internet Options” menu, navigate to the “Security Tab”, and add https://*yourSharepointSite to Local intranet site.

Then restart the browser and try it again.

If you have tried the above methods, however “Open with Explorer” still does not work, try to make sure you have applied the latest updates on the system.

In addition, you can also try to enable Basic authentication on the client computer, by setting the BasicAuthLevel registry entry of the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

share|improve this answer
add comment

Are you using a internal CA for your certificates? Could you test one thing? Install Fiddler (http://fiddler2.com/) on your workstation, enable SSL debugging (tools - options - HTTPS - Decrypt HTTPS traffic).

If you can open your library in Explorer after this then you have a SSL trust issue.

Fiddler replaces the certificate with its own and where the client trust is working. This has happened more than once with my clients but is not documented on many blogs/technet that I know of.

share|improve this answer
    
Just noticed that you are talking about SP2010. I must admit that the trust issue has been on SP2013 environments but it doesnt hurt to try :) –  Funi Magnússon Dec 1 '13 at 23:50
    
Just noticed how old this thread is... Silly me. –  Funi Magnússon Dec 1 '13 at 23:51
add comment

Please try this

http://wmostafaw.wordpress.com/2011/12/08/opening-list-or-document-library-in-windows-explorer/

share|improve this answer
1  
We prefer inclusion of the essential parts of the answer here, and to provide the link for reference. See answer for general guidelines. Please also remember to disclose affiliation (e.g. "I have explained in detail on my blog") with websites - see May I promote products or websites I am affiliated with here? for guidelines. –  SPDoctor Jun 30 '12 at 14:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.