Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Has only tried hiding

The permissions section on new site in sharepoint 2010.

Permissions
You can give permission to access your new site to the same users who have access to this parent site, or you can give permission to a unique set of users.

I do not want users to select unique permissions.

Thanks

share|improve this question

migrated from stackoverflow.com Dec 18 '11 at 13:33

This question came from our site for professional and enthusiast programmers.

add comment

1 Answer 1

If want a no - code solution, you will have to modify the newsbweb.aspx application page.
Be warned this will affect all the web applications.

  • Go to the 14 hive Template\Layouts directory.
  • Save a copy of the newsbweb.aspx file as a backup for when you want to revert
  • Open the file for editing.
  • add a registration line at top

    <%@ Register TagPrefix="wssuc" TagName="InputFormSection2" src="~/_controltemplates/InputFormSection2.ascx" %>

  • Locate the InputFormSection tag which shows the web permissions options to users
    This usually be at line 190 or 191

    <wssuc:InputFormSection runat="server" title="<%$Resources:wss,newsbweb_idInputTitleContent%>" Description="<%$Resources:wss,newsbweb_idInputDescriptionContent%>" id="idPermSection" > <Template_InputFormControls > <wssuc:InputFormControl LabelText="<%$Resources:wss,newsbweb_idInputLabelPermissions%>"

  • Change the start and end tags to wssuc:InputFormSection2

  • Save the file.
  • Now go to the 14 hive Template\ControlTemplates directory
  • Select the InputFormSection.ascx file and create a copy - name it InputFormSection2.ascx
  • Open InputFormSection2.ascx for editing
  • Put style="display:none" in the two main tr tags in the file (lines 9 and 35)

That's all users will not see the permissions option while creating subsite.
Also the subsites created will inherit parent site's permission as that is the default behaviour.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.