Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I created an application in SharePoint, lets call it http://example.com/ and a site collection with the "Empty Site" template.

Since I'm using it locally in a virtual machine in host-only mode, I had to edit my host file to add

127.0.0.1    example.com

Now, whenever I access this website, I cannot click on "Site Action". All it does is add a # at the end of the URL.

Since I'm in a host-only VM, i cannot change the DNS to make it work (that's the way we fixed it for a dev server).

share|improve this question
    
Sorry for the DNS tag, I didn't found anything else and cannot create new ones (like host-file) –  Loïc Wolff Apr 28 '10 at 8:41
add comment

1 Answer 1

up vote 1 down vote accepted

Javascript might be disabled

Try adding example.com to your trusted sites in IE to allow javascript to run on pages within example.com

share|improve this answer
    
Cannot upvote since I don't have enough rep. Very good catch. Thank you. –  Loïc Wolff Apr 28 '10 at 9:05
    
Upvoted for dex. –  Marc D Anderson Apr 28 '10 at 12:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.