Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

i have a multilanguage supported sharepoint 2010 site and in it there is a document library.(english default,turkish installed later) when i click a word document on library if my language selection is english it gives Cannot open file "_layouts/WordViewer.aspx?id=/DokumanMerkezi/file.docx". error and the url on ie adds download.aspx?SourceUrl=http://portakal/_layouts/WordViewer.aspx?id=....&DefaultItemOpen=1&DefaultItemOpen=1

(... etc : my file path)

if i click to open word file when my language for the site is in Turkish it gives no error and open files in word app viewer. here is the link in Turkish http://portakal/_layouts/WordViewer.aspx?id=file... etc

the difference is as you see in english it tries to redirect to download.aspx?Source.. in turkish it directly opens with wordviewer.aspx.. what may be needed to solve this,thanks

share|improve this question

1 Answer 1

This sounds a lot like a bug in Office Web Apps.

When Office Web Apps is installed, it overrides the file links in sharepoint. It looks like there is some language selection related error in the functionality that does the overriding. Could you try enabling / disabling the "Always open in client application" site collection feature?

share|improve this answer
    
i activated Open Documents in Client Applications by Default feature,and then deactivated it. nothing seems changing. –  cranfan Dec 18 '11 at 19:29
    
i disabled both office web apps and open docs in client..Both xlviewer.aspx and wordviewer by default is opened in turkish but in english it redirects to download.aspx, i guess this is not directly office web apps related. –  cranfan Dec 18 '11 at 19:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.