Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am writing an event handler that will create a new site whenever the new item is added to the list. My issue is it creates a new site everytime but it does and does not (randomly) execute the code following the Webs.Add(..). It looks like creating a new site somehow explodes without being caught by try catch.

This issue is on a Sharepoint Online environment (so impossible to debug) but works perfectly fine on a sandbox solution(on the developer machine VM).We are using team site templates.

I initially suspected to be some kind of threading related issue so my even handler is singlton, but that didnt help.

share|improve this question
    
Could this be a permissions issue? Does the user adding the item have permission to create a site? –  Stuart Pegg Jan 4 '12 at 21:21
2  
Can you post your code here? I really think it might be something with the code. –  Vardhaman Deshpande Jan 11 '12 at 16:30

1 Answer 1

There's a 30 second execution cutoff in SharePoint Online (not sure about wave 15 yet). Have a look at your stopwatch, at the 30s mark the code will die without throwing an error. It probably works as a sandbox solution on your dev machine because it is faster.. Yes I have experienced this before.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.