Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We recently signed up for Office 365 and are in the process of building out oure SharePoint site.

We started with the default site, a Team Site and have built out the following site map:

  • Site
    • Sub Site 1
    • Sub Site 2
      • Sub Site 3
      • Sub Site 4
    • Sub Site 5

The main navigation appears as:

Sub Site 1 | Sub Site 2 | Sub Site 5

We would like a drop down menu to appear when the user hovers over Sub Site 2, showing the Sites under that Site.

It looks like SharePoint 2010 supports this, for the life of me I can't seem to get the settings right to make this work.

Any help would be appreciated!

Per the recommendation below ... I located the following:

<SharePoint:AspMenu
      ID="TopNavigationMenuV4"
      Runat="server"
      EnableViewState="false"
      DataSourceID="topSiteMap"
      AccessKey="<%$Resources:wss,navigation_accesskey%>"
      UseSimpleRendering="true"
      UseSeparateCss="false"
      Orientation="Horizontal"
      StaticDisplayLevels="2"
      MaximumDynamicDisplayLevels="1"
      SkipLinkText=""
      CssClass="s4-tn"/>

It looks correct ... but menus still not displaying.

So I made those changes in the master page ... and then I checked the box below:

enter image description here

I do get a drop down menu, but now it seems my links are duplicated:

enter image description here

share|improve this question
add comment

1 Answer 1

up vote 6 down vote accepted

Find the SharePoint:AspMenu control with the ID TopNavigationMenu in the masterpage and set these values

StaticDisplayLevels="X"
MaximumDynamicDisplayLevels="X"
share|improve this answer
    
I just want to make sure ... so there is no setting or configuration to just make this work? –  mattruma Dec 19 '11 at 17:52
    
Not through the SharePoint UI, no. –  Daniel Ziga Dec 19 '11 at 18:54
    
Can you take another look at my question ... I included the text ... it looks correct. –  mattruma Dec 19 '11 at 19:42
1  
You need to change MaximumDynamicDisplayLevels to something greater than 1. –  James Love Dec 19 '11 at 19:50
    
@mattruma What JamesLove said :) –  Daniel Ziga Dec 19 '11 at 21:44
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.