Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm working on a custom search results page, located in the layouts folder. The idea is that depending on the site where the search was performed, the refinement panel will be shown or not (as asp:panel is shown or hidden accordingly). I mention this to explain why I'm creating a custom application page, rather than just a regular SharePoint page in a Pages library.

A colleague is creating a bunch of custom refinements, so the refinement category Managed Metadata Columns is needed, but all the default categories (site, author, etc) should be removed. To achieve this we customized the FilterCategoriesDefinition.

Naturally in order to use this custom FilterCategoriesDefinition we also have to set UseDefaultConfiguration to be False. However, when we do this last part, the rendering of the refinements panel is broken - see screenshot below.

If I reset the web part to use the default FilterCategoriesDefinition (i.e. I add the web part to a page in SharePoint Designer, then copy the full web part definition to my custom page) and only change UseDefaultConfiguration to be False, the rendering is still not working correctly.

We tried this on a relatively unchanged ootb SharePoint Server 2010 installation, with default master pages and page layouts (i.e. no branding), and the same issue exists there, so I'm suspecting my heavily branded site is not the issue.

Any ideas?

Here's a screenshot of what I mean: enter image description here

share|improve this question
    
I have had the same issue after altering a search results page (in an Enterprise Search Center) in SharePoint designer. My solution was to export the working web part before I made changes to my page, then reimport it afterwards. Naturally, I don't think this will apply for you, but I wonder if there is a problem with the 'save' action of a refinement panel when altered in SPD. –  Andy Burns Dec 14 '11 at 11:23
    
In the end I had to use JavaScript and CSS trickery to resolve this hiding the ootb refinements, and leaving "UseDefaultConfiguration='true'" in the web part properties. Not ideal, but it works. If anyone every needs to know how I did it, just reply and let me know. –  QMKevin Dec 23 '11 at 15:02
    
it fails in spd 2010, but when i use the webpart configuration panel in internet explorer, it works :S –  user6626 Jan 28 '12 at 21:57

2 Answers 2

up vote 2 down vote accepted

QMKevin,

Maybe i found a solution:

In the refinement webpart, view this section:

> <Xsl> <?xml version="1.0" encoding="utf-8"?> <xsl:stylesheet
> version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
> xmlns:ddwrt="http://schemas.microsoft.com/WebParts/v2/DataView/runtime"
> xmlns:ddwrt2="urn:frontpage:internal">

remove

<?xml version="1.0" encoding="utf-8"?>

maybe spd2010 add this line to define the xml version, but the webpart don´t need this line.

try and tell me... on monday i continue trying solve this bug, i'm tired.

share|improve this answer
    
it might be a while before I test this. We're just in the last stages of finishing our site and deploying it, so it's all hands on deck with that for the new few weeks. I'll try and remember to give this a shot though. Thanks :) –  QMKevin Feb 12 '12 at 2:55
    
QMKevin, try my solution, this works. –  Lionel Carrillo Feb 13 '12 at 21:08
    
As I said, it might be a while before I tested this. Well, I just did and removing that line seemed to do the trick! Thanks Lionel :) –  QMKevin Apr 24 '12 at 14:04

Normally, when you edit the refinement panel web part in the site, you get an option to uncheck the 'Use Default Configuration' at the bottom. Did you try changing this field from the UI and then modifying the same in SharePoint Designer rather than making the UseDefaultConfiguration to be False in SPD?

share|improve this answer
    
I don't understand what you're suggesting. I want to turn on UseDefaultConfiguration, so that in Designer, and on a page that cannot be edited in the UI (i.e. custom application page), I can specify my own configuration, but when I do I get the above rendering. Using the UI to see what the web part properties should be is what I'm doing, and setting 'UseDefaultConfiguration' = 'false' is what the UI change does... it just doesn't work. –  QMKevin Dec 19 '11 at 13:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.