Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

The global navigation of my site automatically includes links to the sub-sites (c/o the 'Show Subsite' checkbox). These auto-included navigation links aren't editable (at least, not through the standard method of highlighting the nav item and clicking the 'edit' button - which itself is greyed-out for the auto nav items).

The URLs of these subsites nav items all point to the relevant site's main folder by default i.e. http://intranet/site1. Except for one, which is pointing to http://intranet/site2/default.aspx.

I suspect at some point this site had a different home page set and it was later changed back by specifically setting default.aspx as the new home page.

This particular site doesn't work with the standard nav item highlighting functionality as the relevant (default) 'selected' CSS classes aren't applied to the list item.

The only difference between this item and the other auto ones is the URL specifying the file rather than the folder so I'd like to know -

Is it possible to change this URL and where do I it?

Edit: I can confirm that setting a page as the homepage within any sub-site breaks the OOTB sub-site navigation options & highlighting in SharePoint 2010. Does anyone know where I might be able to fix this or see the variables used within SharePoint Manager 2010 v2?

share|improve this question
    
If anyone knows where in the database this information is stored so I can update it, I'd love to know! Not sure if that'd be the quick & kosher fix. –  Beeblebrox Dec 9 '11 at 5:38
    
No, it isn't. Updating the database directly will put you in an unsupported state. –  PirateEric Dec 9 '11 at 16:36

1 Answer 1

I just encountered the highlighting problem. As impossible as it may sound, if you include a page or even a slash in the URL, highlighting won't work. http://intranet/site1 will have proper highlighting, http://intranet/site1/ will fail.

You can try to hide the URL that causes the problem and add a new heading with the same URL without the page and ending slash, eg. http://intranet/site2

share|improve this answer
    
Thanks @panagiotis-kanavos, That's the first thing I tried (adding new links). I tried intranet/subsite, intranet/subsite, intranet/subsite/default.aspx, /subsite, /subsite/... No luck, however! I can't believe how fiddly this is. –  Beeblebrox Dec 15 '11 at 22:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.