Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have Site level Feature. I have created a mapped a SharePoint folder to ISAPI. I have added a folder (myfolder) into the ISAPI folder. I have created a .svc (endpoint.svc) file and a web.config file in that folder.

When I deploy my solution and hit the svc endpoint (/_vti_bin/myfolder/endpoint.svc) I get:

The service '/_vti_bin/myfolder/endpoint.svc' does not exist.

If I browse C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\ISAPI I can confirm that the file is not there.

Why would my file not be being deployed to the ISAPI folder?

I was trying to follow the example in this video http://blah.winsmarts.com/2010-3-Video__Telerik_Silverlight_Chart_showing_live_data_from_SharePoint_2010.aspx

share|improve this question
    
You said you already created a file at ISAPI, so why you deploy again? –  Amit Kumawat Dec 8 '11 at 15:26
    
I created the file in VS2010. When I deploy my feature it should copy the file to ISAPI. –  John Dec 8 '11 at 15:50

3 Answers 3

up vote 1 down vote accepted

First thing to look at would be the contents of your solution package (wsp). Perhaps the mapped ISAPI folder is not being included in the package.

Within Visual Studio, open the Package.package file.

1.) In the design view, your ISAPI mapped folder should be in the right hand pane (Items in the package)

2.) If you switch to the manifest view, there should be a <RootFiles><RootFile Location="..."> entry for your .svc

Alternately, you can rename the .wsp to a .cab file and open it up in windows explorer to see whats included in the built package.

Note that mapped folders should be deployed regardless of features (ie you can't deploy a mapped folder through feature activation/deactivation AFAIK)

share|improve this answer
    
Option 1 was my problem. –  John Dec 9 '11 at 13:38

Check the properties for the files that are not being deployed/copied.

  • Make sure that Copy To Output Directory is set to either "Copy Always" or "Copy if Newer" depending on your preference.
  • Check that the Deployment Location is set to something like "{SharePointRoot}\ISAPI\".
share|improve this answer

Not an answer (hate that I can't comment yet and not even up-vote), just an observation based on Paul's answer.

The subtle clue in Paul's answer that helped me realize the mistake in my implementation is that deploying to a mapped folder (ISAPI, in my case) isn't supported using Modules. Switched back to using a mapped folder and all worked well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.