Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

On an existing SharePoint 2010 site, we have a problem with first time visitors. The site is setup to be multilingual. The server installlation is English, there is an additional Dutch language pack installed. I have had several reports from Dutch users claiming the site displays dates in english format and currencies as dollars instead of euro's.

The weird thing is, an F5 refresh corrects this and the problem never occurs again, it seems untill the application pool is reset. For sites which aren't loaded in the current session / apppool and are then queried; the first request seems to end up in English, all other requests are properly handled in Dutch.

Weird problem, anyone has any ideas?

share|improve this question
    
Are you using Variations? Have you set the correct locale settings for the Dutch variation? –  James Love Dec 6 '11 at 18:19
    
No, no variations. I create the site in the correct language, all the custom webparts, pages and other stuff use Dutch texts. After the first load, everything seems fine so that leads me to think my settings are ok. –  Jasper Dec 6 '11 at 19:27
    
Is this happening in your custom web parts or on default columns like created and modified date? –  Deepu Nair Dec 7 '11 at 0:45
    
Good question, I'm not 100% sure. Untill now I only noticed it on custom webparts. –  Jasper Dec 7 '11 at 15:38
1  
I can confirm this behaviour. You should be able to trigger it on a dev machine with a vanilla SP install. Just create a site collection with a language other than the default, then navigate to a page of the collection - for example the site collection feature page. Do an iisreset, then reload the page. On the first load only the page will display with the default language. PS: I have reported the same behaviour on all SP 2010 installation I have see so far. –  SPArchaeologist Dec 27 '11 at 16:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.