Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We have a publishing page on a SharePoint 2010 server; it display a list view which has this turned on under the web part's Miscellaneous tab: [X] Enable Data View Caching (Data View Caching Time-out (seconds) 86400).

Now we've disabled this and it's still not showing the latest data. If I go to the list view directly, it shows the correct data; on the publishing page, it shows the old data.

Any ideas what's causing this? We want the user to see the latest data each time the pub page is loaded. Thanks.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Does the site have any caching profile enabled? If the site has one enabled it might be caching the entire output of the page even though the webpart has been modified.

share|improve this answer
    
Thanks, mcnarya. How do I check to see if caching profile is enabled? –  Alex C Dec 7 '11 at 5:20
    
If you are a Site Admin you can go to Site Actions > Site Settings. From there in the bottom right should be a section called Site Collection Administration. Click on Site collection output cache. The first couple of items should tell you. Is Enable output cache checked? If so, try unchecking it. That will disable caching. Are the profiles listed for Default Page Output Cache Profile something other than Disabled? If so you can go into the Cache Profiles page (from the site settings page) to see how the profiles are setup. –  mcnarya Dec 7 '11 at 15:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.