Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Right now I have a Custom Workflow Activity, I've developed on a test server and it's working fine. However when bundled into a .wsp on the test server and deployed to production, SharePoint Designer 2007 doesn't even see the workflow. I've already checked the following:

  • GAC on production server, it's there, same version as test
  • Workflow .actions file is perfectly in sync between test and production
  • Opened up the .cab and checked the feature.xml file, all looks ok.

I'm guessing it's a server sync issue of some sort, but where would I start from here?

EDIT: It's a farm scoped feature, verified it's installed and deployed.

share|improve this question
add comment

closed as too localized by tekiegreg, PirateEric, Kit Menke Dec 12 '11 at 23:09

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

I would check to verify the feature is enabled at whichever scope it is set (Farm, WebApplication, Site, or Web).

share|improve this answer
    
Good idea, though I checked and it's enabled. –  tekiegreg Dec 5 '11 at 22:50
    
Have you tried retracting, removing, reading, and redeploying it? –  John Chapman Dec 5 '11 at 23:56
    
I would, but at this time we just made a business decision not to proceed further with the issue. So ultimately we won't test. –  tekiegreg Dec 6 '11 at 0:40
add comment

Ensure that the workflow activites are registered in web.config by your feature. For e.g.

 <System.Workflow.ComponentModel.WorkflowCompiler>
    <authorizedTypes>
      <authorizedType Assembly="System.Workflow.Activities, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" Namespace="System.Workflow.*" TypeName="*" Authorized="True" />
share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.