Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We are using SharePoint 2010. We are having a problem with the web part “People Search Box”. We created a custom page from a page layout and added the web part.

We have edited the web part and changed the "Target search results page URL" under miscellaneous to point to our custom page. Example: colleagueSearch.aspx.

No matter what we try when we search it browses to “PeopleResults.aspx”. Does anyone know why this is happening and how to fix it?

share|improve this question
    
This is the correct behavior for the people search results. The people search results and content search results pages are different, and use different formatting. Could you better explain what you're trying to do? You can edit the results page for people search through the People scope configuration on the search SSA, but without some more information on what you're doing, that may or may not meet your needs. –  webdes03 Jun 7 '12 at 18:01
    
did you ever get a solution for this issue? I am experiencing the same fault and I dont believe that it is by design as it worked perfectly on SP2007. Its only since our in-place upgrade that the search keeps ignoring the "Target search results page URL" and going to /searchcenter instead. The only workaround I have found is to use a standard search and force the people scope but that looses the people specific options. Thanks in advance! –  user8811 Jun 12 '12 at 9:12
    
Hi, @David are you able to fix this/ or find any solution related to this issue. I am facing same issues. People Search box redirection only work in case of search drop down(for poople scope I gave my custom page url). –  Basant B. Pandey Oct 29 '13 at 6:36

2 Answers 2

The People scope by default sets the results page to peopleresults.aspx.

On the PeopleSearchBoxEx control add UseSiteDefaults="False"

<SPSWC:PeopleSearchBoxEx
     ID="MySiteGlobalSearchBox"
     FrameType="none"
     HonorUseSiteDefaults="true"
     IsMysiteSearchBox = "true"
     SearchResultPageURL="/Pages/colleagueSearch.aspx"
     UseSiteDefaults="False"
     DropDownMode="HideScopeDD"
     ShowSearchOptions="false"
     GoImageUrl="_layouts/images/gosearch15.png"
     GoImageUrlRTL="/_layouts/images/ppl_search_normal_rtl.png"
     GoImageActiveUrl="_layouts/images/gosearchhover15.png"
     GoImageActiveUrlRTL="/_layouts/images/ppl_search_active_rtl.png"
     QueryPromptString="<%$Resources:sps,MySiteTopNav_PeopleSearch_Text%>"
     runat="server" __WebPartId="{47960F99-AD7F-4CEE-BACA-B1168290112E}" WebPart="true"/>

Alternatively, you can change the People scope target results page, remove the SearchResultPageURL and set UseSiteDefaults="true"

share|improve this answer

I'm not for certain, but I think you need to associate the page with a specific search scope. See http://sharepointmagazine.net/articles/customizing-search-series-created-the-custom-results-page.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.