Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We have a public facing website which is custom branded. Up until viewing the website in IE9 all standard Sharepoint functionality worked such as Site Actions.

All browsers work with it. Recently when we updated to IE9 the second level drop down has stopped working. I considered it to be a CSS related issue on our end, so I cleared the possibility of that by disabling it and it still didnt work.

I haven't managed to find a solution which works so wondered if anyone can shed a light on this problem.

share|improve this question
    
Do you have an emulate mode declared in the master page for the site? –  PirateEric Dec 5 '11 at 13:58

3 Answers 3

There are some known issues with IE9 and SharePoint 2007's JavaScript, etc. You might set the IE Compatibility Mode meta tag in the master page so that it forces IE 9 to render in IE 7 or 8 mode:

i.e: < meta http-equiv="X-UA-Compatible" content="IE=7" / >

http://msdn.microsoft.com/en-us/library/cc288325(v=VS.85).aspx

share|improve this answer
1  
You can also use the IE9 developer toolbar to force a different compatibility mode only on your client. This could be usefull if you need to isolate the issue before taking further action. –  SPArchaeologist Dec 5 '11 at 16:22
    
^^ Agreed. See if that fixes the issue on your machine, and if so, use the META tag. –  John Chapman Dec 5 '11 at 16:27
    
Where can I find a list of the known issues with IE9 and SharePoint 2007? We are currently emulating IE "standards" as shown above but I want to use IE9 so we can stop having to develop special code for IE. –  xr280xr Jul 30 '13 at 20:18
    
I am not aware of any such list. A cursory search only brings back specific issues people have come across, nothing comprehensive. –  John Chapman Jul 30 '13 at 21:31

If its not a JavaScript issue, I would also suggest to try to launch IE9 with no addons. If it works, then you should find the respective addon that is creating the problem and disable it.

share|improve this answer
    
I had this with SharePoint 2010 and IE9, and it was the latest DivX plug-in in my case (and this guy's as well) Disabled it and restarted IE. –  techie007 Dec 17 '11 at 18:53

You should make sure that JavaScript is enabled on your browser, Fast way to do this:

While in IE9, hit the F12 key on the keyboard You will see the Developer tools appear at the bottom of the screen. From the Disable menu, confirm that 'Script' is not ticked.

If this doesn't work, make sure there are no JavaScript errors occurring on the page.

Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.