Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

After not getting much help on the last question, I decided to blow away the VM and re-create it as I already lost a week on this issue. And of course still issues, btu a little different.

I am using WSS on a 2008 server. I removed from the SharePoint admin the blocked asmx page types. I am using the administrator account with password and the domain, which is the IP of the VM machine. Normally I would never recommend using the admin account, but since I am just running a test to connect to SharePoint web services, so be it.

When accessing this site via a webbrowser, no issues whatsoever.

enter image description here

When accessing the web services from the browser using the admin credentials, no problem.

enter image description here

Then when trying to access the web service via Visual Studio I get the windows security dialog;

enter image description here

Followed by a discovery credential for the list;

enter image description here

Followed by another Discovery Credential for access to the error.aspx page, but as you can see, I can see the list of services for lists.asmx;

enter image description here

Followed by yet another Discovery Credential asking for permission to the $metadata and this just continues continually -it will NEVER authenticate via visual studio 2010;

enter image description here

And then, of course, when the code is ran, what do we get - ACCESS DENIED.

Call made; code not listed makes connection.

Make call to service:

enter image description here

And receive the error.

enter image description here

enter image description here

And IIS for SharePoint is set top Windows Authentication and Impersonate. All defaults.

enter image description here

It has now been going on 5 days; does anyone at all have any clue as to what is causing this? I have used this code and technique for years with Windows Server 2003 and WSS 2.0 and / or MOSS 2007 connecting from remote machines and NEVER, I mean NEVER had issues like this.

I would really appreciate any help.

UPDATE

_lists = new Lists
   {  //Proxy = null,
      Credentials = new NetworkCredential(UserName, Password, Domain),
      Url = "http://192.168.56.102/_vti_bin/Lists.asmx",
      UseDefaultCredentials = true <- Setting this to true or false throws access denied.
   }; // Reference the list object.

If you remove the UseDefaultCredentials completely you no longer get access denied.

_lists = new Lists
   {  //Proxy = null,
      Credentials = new NetworkCredential(UserName, Password, Domain),
      Url = "http://192.168.56.102/_vti_bin/Lists.asmx"
   }; // Reference the list object.

But there is still the 30-60 second lag time. Any ideas?

share|improve this question
1  
Is this really a different question to sharepoint.stackexchange.com/questions/24462 ? If you want to add to your original question please edit it. Also you might want to keep your question as specific and succinct as possible as this will improve the chances of getting help. See ask for general guidelines. –  SPDoctor Dec 4 '11 at 0:06

3 Answers 3

I assume you've checked the following?

  1. Run Visual Studio as Administrator
  2. VS on the same machine? Check the DisableLoopbackCheck registry property (there's a KB for this at http://support.microsoft.com/kb/896861 )
  3. use the machine name in the username field, not the IP address (MACHINE\Administrator)

There are a few other possibilities, but these are the most common I see.

share|improve this answer

When adding to Visual Studio you should use the URL as - http://yourserver/sites/yoursite/_vti_bin/lists.asmx?wsdl

share|improve this answer
    
That doesn't change anything unfortunately. :( Thank you for the reply though... –  nitefrog Dec 3 '11 at 8:47
    
Interestingly and surprisingly, it would appear that this has done the trick for me in Visual Studio 2012. –  mwardm Jan 16 at 23:39

This question is quite old: It sounds like the famous "Loopback check" error. Try this solution here: http://support.microsoft.com/kb/896861/en

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.