SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to enable/activate the SharePoint Server Publishing Infrastructure and then the SharePoint Server Publishing but when I click on activate I get the error below. Any ideas and thanks in advance

Server Error in '/' Application.

Runtime Error Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a tag within a "web.config" configuration file located in the root directory of the current web application. This tag should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File -->

        <customErrors mode="Off"/>

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
share|improve this question
can you open the web.config, modify the <customErrors mode="On"> and then try activating the feature. You should be getting a detailed error then. – Deepu Nair Dec 1 '11 at 4:18
It would also be a good idea to become familiar with how to real the ULS logs stored within the logs directory of the SharePoint root. The details of the issue should be logged there. – Mike Oryszak Dec 1 '11 at 4:20
Thks guys.Trying to sort that out as need access to confirm that.I'd try using powershell or stsamd to get it activated first and see how it goes – naijacoder Dec 1 '11 at 4:29
try creating a new web app with a new site collection. If it works, compare web.config files, and activated features across the two sites – David Lozzi Dec 1 '11 at 14:37
This error is also logged into The Windows eventlog. Please look there and add The Info to your question – Sascha May 21 '14 at 18:36

Can you activate it with PowerShell using the below Cmdlet:

Enable-SPFeature –Identity PublishingSite –url <SiteURL>
share|improve this answer

Try to activate the feature through STSADM command...

stsadm -o activatefeature -name publishingsite -url server:20

You can use the codeplex tool "SharePoint Manager" here to set the "Allow delete property " to true.

If this doesn't work: Open the list in browser, delete it and then try to activate the feature.

share|improve this answer
(... strange, seems that normal link markdown isn't working in this answer. Leaving this comment as a reminder to check later) – SPArchaeologist Dec 6 '12 at 10:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.