Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

For some reason the "View all site content" link in the Site Actions menu is missing for sites that do not use the Publishing feature. The moment I enable the Publishing feature for the site the link appears (along with 2view reports" and "manage content and structure"). I can't remember ever having seen before. Or am I being silly and this is the expected behaviour? If it is, is it possible to somehow display the link for sites that don't use the Publishing feature? I use a customized master page and the quick launch menu is hidden on the page itself - hence the need for being able to access the link via the Site Actions menu.

Thanks in advance.

Ps. I run MOSS SP2

share|improve this question

2 Answers 2

I hate to be the bad messenger, but MOSS 2007 indeed does not have a "View all site content" link on non-publishing enabled sites on the "Site Actions" dropdown menu.

While it would be possible to add it directly to your masterpage, you would end up with two links if somebody decides to activate the publishing features.

Instead I'd wrap it into a feature with a custom action like this:

<CustomAction Id="ViewAllSiteContent"
  GroupId="SiteActions"
  Location="Microsoft.SharePoint.StandardMenu"
  Sequence="14"
  Title="View All Site Content"
  Description="View all libraries and lists in this site."
  ImageUrl="/_layouts/images/vwcntnt.gif">
    <UrlAction Url="~site/_layouts/viewlsts.aspx" />
</CustomAction>

This would make it possible to turn it on and off whenever you like.

share|improve this answer
    
+1 I see this as well in our environment. Only publishing sites have the view all site content link in the Site Actions menu. –  Kit Menke Nov 29 '11 at 14:59

That is by design from my experience.

If your custom master page does not contain a left navigation control on it, then you won't see a View All Site Content link in non-publishing enabled sites unless you add a link to it someplace.

I've run into this before where I have a custom master page with no left navigation. I had created a Pages library and because of that, I cannot enable the publishing features to get View All Site Content in the Site Actions menu. My workaround was to create an audienced link in the top navigation.

share|improve this answer
    
Hmmm, Interesting find. I tested it with MOSS 2007 and a Team Site template with the default.master. No "View All Site Content" on the "Site Actions" dropdowm even though it is visible on the left navigation and I am Site Collection admin. –  Sig Weber Nov 29 '11 at 14:07
    
Right, you have to turn on the publishing features for that to occur. We have 2 web apps both as team site base templates. One has publishing enabled w/ no left nav and the VASC link is in the Site Actions. The other is a team site with no left nav, but since I already have a pages library I created, I cannot enable the publishing features so the VASC link had to be manually created in Navigation and audience targetted. –  PirateEric Nov 29 '11 at 17:50
    
Big thanks to everyone for the replies. I guess I'll have to rely on links then (I don't have Dev resources to write a custom feature even though it would probably be the preferable approach). I was thinking to just create a CEWP webpart with a link to the –  Greg Farlan Nov 29 '11 at 18:20
    
Pressed Enter too early and couldn't finish the comment (can't edit it any more). Continued from comment above: I tried to create a CEWP webpart that links to the _layouts/viewlsts.aspx page but I haven't been able to get the link to dynamically append the URL of the current site yet. I tried the solution from here (stackoverflow.com/questions/1634449/…) but the link wont resolve if I put the below in a CEWP: <a href='<SharePoint:ProjectProperty Property="Url" runat="server"/>/_layouts/viewlsts.aspx'>View all site content</a> Will try some more –  Greg Farlan Nov 29 '11 at 18:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.