Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a page where I am using dataview webpart that has 2 diferent list as datasource ... I am working on the page in Sharepoing Designer 2007 and see that it does work good. But when I try to see it in browser, it gives below error -

An unexpected error has occurred.

Web Parts Maintenance Page: If you have permission, you can use this page to temporarily close Web Parts or remove personal settings. For more information, contact your site administrator. Troubleshoot issues with Windows SharePoint Services.

0 Table

Below is the code in my page:

<WebPartPages:DataFormWebPart runat="server" SuppressWebPartChrome="False" Description="" PartImageSmall="" DataSourceID="" MissingAssembly="Cannot import this Web Part." ListName="Autorizacion SAO" FrameType="Default" ConnectionID="00000000-0000-0000-0000-000000000000" DetailLink="/SCMPlanificacion/VP00/Autorizacion SAO/Forms/DVWP.aspx" ExportControlledProperties="True" IsVisible="True" AllowRemove="True" AllowEdit="True" ID="g_498a8b5c_487b_4b0a_9c43_b8a6ce201d2d" Dir="Default" FrameState="Normal" DisplayName="DVWP" ViewContentTypeId="0x" AllowConnect="True" PageSize="100" Default="TRUE" AllowMinimize="True" IsIncludedFilter="" TitleUrl="/SCMPlanificacion/VP001245/Autorizacion SAO/Forms/DVWP.aspx" ShowWithSampleData="False" HelpMode="Modeless" ExportMode="All" ViewFlag="1" Title="Autorizacion SAO" HelpLink="" AllowHide="True" AllowZoneChange="True" PartOrder="1" UseSQLDataSourcePaging="True" PartImageLarge="" IsIncluded="True" NoDefaultStyle="TRUE" __MarkupType="vsattributemarkup" __WebPartId="{498A8B5C-487B-4B0A-9C43-B8A6CE201D2D}" __AllowXSLTEditing="true" WebPart="true" Height="" Width="">
    <DataSources>
        <SharePoint:AggregateDataSource runat="server" IsSynchronous="" SeparateRoot="true" RootName="" RowsName="">
            <Sources>
                <SharePoint:SPDataSource runat="server" DataSourceMode="List" SelectCommand="&lt;View&gt;&lt;Query/&gt;&lt;/View&gt;" UseInternalName="True" IncludeHidden="True">
                    <SelectParameters>
                        <asp:Parameter DefaultValue="Autorizacion SAO" Name="ListName"></asp:Parameter>
                        <asp:QueryStringParameter QueryStringField="RootFolder" Name="RootFolder" Type="String"></asp:QueryStringParameter>
                        <asp:Parameter DefaultValue="0" Name="StartRowIndex"></asp:Parameter>
                        <asp:Parameter DefaultValue="0" Name="nextpagedata"></asp:Parameter>
                        <asp:Parameter DefaultValue="100" Name="MaximumRows"></asp:Parameter>
                    </SelectParameters>
                    <UpdateParameters>
                        <asp:Parameter DefaultValue="Autorizacion SAO" Name="ListName"></asp:Parameter>
                    </UpdateParameters>
                    <InsertParameters>
                        <asp:Parameter DefaultValue="Autorizacion SAO" Name="ListName"></asp:Parameter>
                    </InsertParameters>
                    <DeleteParameters>
                        <asp:Parameter DefaultValue="Autorizacion SAO" Name="ListName"></asp:Parameter>
                    </DeleteParameters>
                </SharePoint:SPDataSource>
                <SharePoint:SPDataSource runat="server" DataSourceMode="List" SelectCommand="&lt;View&gt;&lt;/View&gt;" UseInternalName="True">
                    <SelectParameters>
                        <asp:Parameter DefaultValue="Tasks" Name="ListName"></asp:Parameter>
                    </SelectParameters>
                    <UpdateParameters>
                        <asp:Parameter DefaultValue="Tasks" Name="ListName"></asp:Parameter>
                    </UpdateParameters>
                    <InsertParameters>
                        <asp:Parameter DefaultValue="Tasks" Name="ListName"></asp:Parameter>
                    </InsertParameters>
                    <DeleteParameters>
                        <asp:Parameter DefaultValue="Tasks" Name="ListName"></asp:Parameter>
                    </DeleteParameters>
                </SharePoint:SPDataSource>
            </Sources>
            <Aggregate>
                <concat name="data source">
                    <datasource name="Autorizacion_SAO" id="0" Type="SPList" />
                    <datasource name="Tasks" id="1" Type="SPList" />
                </concat>
            </Aggregate>
        </SharePoint:AggregateDataSource>
    </DataSources>
share|improve this question
    
What's the problem? –  Paul Lucas Nov 25 '11 at 0:27
    
I suggested that Perla post over here when s/he asked a question on my blog. Obviously, some context and a specific question would be helpful, Perla. –  Marc D Anderson Nov 25 '11 at 0:29
    
Hi Lucas and Mark the problem is this im trying to re-use one dataview webpart in a diferent site but it doesnt work good :'( i need help pls –  perla DVWP Nov 25 '11 at 5:19
    
Hi Lucas and Mark the problem is this im trying to re-use one dataview webpart in a diferent site but it doesnt work good :'( i need help pls –  perla DVWP Nov 25 '11 at 5:21
    
You haven't included many details in your question? –  Ryan Nov 25 '11 at 9:26
show 4 more comments

3 Answers

If you use a Dataview Webpart of one site in another site, It will not work as it refers sites and lists by GUIDs which will change even if their name are same.

Try to update the GUIDs as well.

share|improve this answer
    
As you can see in the posted code, Perla has switched from ListID to ListName. This helps to make the DVWP more portable from site to site. –  Marc D Anderson Nov 27 '11 at 23:44
    
hi Mark i found the error ... :( but i istill without to know how to resolve it ... My list Autorizacion SAO and Tasks are linked by a field called @WorkflowLink then but i dont know how can i chanced this Value field for the new one ... is like embebed field or internal field coz i dont know where can i change this value :S I hope so someone cans help me pls –  perla DVWP Nov 28 '11 at 16:10
add comment

I don't see anything obviously wrong. I'd check to make sure that the list names are exactly the same in the two sites.

The only other thing that I see that looks a little odd is that the selectcommand for the Autorizacion SAO list has a <Query/> in it which isn't needed.

Finally, the error you are getting isn't normally the one you would get if you have an error in a DVWP. It usually indicates a different type of issue, so check that you haven't inadvertently inserted or removed something else when you added the DVWP to the page.

share|improve this answer
    
hi Mark i found the error ... :( but i istill without to know how to resolve it ... My list Autorizacion SAO and Tasks are linked by a field called @WorkflowLink then but i dont know how can i chanced this Value field for the new one ... is like embebed field or internal field coz i dont know where can i change this value :S I hope so someone cans help me pls –  perla DVWP Nov 28 '11 at 16:05
    
my webpart is trying to use the same value from first site in new one site (@WorkflowLink) HELP MEE PLS :'( –  perla DVWP Nov 28 '11 at 16:14
    
That sounds like an issue with how you created the lists, not anything to do with the DVWP itself, as I suspected. The DVWP will want the lists to have the same structures and be related in the same way as in your original site. –  Marc D Anderson Nov 28 '11 at 17:49
add comment

Maybe, the XSLt for that webpart is somewhere wrong! Check in log files, is there any lines related this error. That'll help you solve the issue easily.

share|improve this answer
    
hi Shantha I found the error ... :( but i istill without to know how to resolve it ... My list Autorizacion SAO and Tasks are linked by a field called @WorkflowLink then but i dont know how can i chanced this Value field for the new one ... is like embebed field or internal field coz i dont know where can i change this value :S I hope so someone cans help me pls –  perla DVWP Nov 28 '11 at 16:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.