Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a SharePoint 2010 site using Forms Based Authentication (ASP.NET Membership)

  1. User (A) logon to the SharePoint site.
  2. Opens a document for editing in Word.
  3. Word displays form for login. User fills out FBA form to login.
  4. Checks "Remember me"
  5. Edits document and saves.
  6. User (A) logs out.
  7. User (B) logs in and does the same as user (A). But will not be asked for username/password before editing document. When user (B) saves the "Modified by" are still the user (B).

How can I make sure the "Modified by" field always sets the current user? Am I missing something in the FBA config?

share|improve this question
    
What steps does user B repeat? All of them? Do you mean that when user B edits a document on te pc of user A, the document should be "modified" by user A? –  Ruben Herman Nov 23 '11 at 14:02
1  
When user B edits the document it should be 'modified' by user B. Now it's beeing modified by user A even if user B is the logged on user. This only occurs when user A logged on first with the 'remember me' option checked. –  stiangodo Nov 23 '11 at 14:16
    
I don't think there's something you can do about this in sharepoint. The problem is that your browser is using the password and user that is stored in it. Maybe you can set somewhere in your browser that no username or passwords can be stored? –  Ruben Herman Nov 23 '11 at 14:23
    
By "User (B) logs in" are you referring to the user logging into Windows or simply into the browser? Also, was Word closed between step 5 and step 7? –  Dave Wise Nov 23 '11 at 15:01
    
What if you remove SharePoint site from Intranet or Trusted Sites in Internet Options on the Security tab? A manual process would be to remove stored credentials, but accessing this depends on OS you use. If windows 7, type "cred" in Windows search and open credentials manager. From there you can remove saved user credentials. For XP, in the Control Panel open User Profiles, choose your profile and on the left side you have an option to access stored network passwords. (I could be mistaking, because writing from top of my head) –  Janis Veinbergs Nov 23 '11 at 15:10
add comment

1 Answer 1

up vote 1 down vote accepted

All office apps use their own internal browser when requesting files from a web site so that when you are authenticating in Word, you are authenticating Word's internal browser to use that ID.

As long as that instance of Word is running, it doesn't matter who you subsequently log into the website as because Word's internal browser is still using the original credentials provided when Word opened.

to get around the issue you are seeing, you can do any of the following

  1. Close Word before logging in as the other user
  2. Log into Windows as the other user
  3. Use different machines to test the different users
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.