Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have created new site in SharePoint using WSS, but when i try to browse the site from IIS i get no page found...

but i have one site that is in central administrator that is running fine...

i have screen shot here...what can be the reason?

alt text

Thanks..

share|improve this question

7 Answers 7

What is the URL to your site?

If your are using hostnames you must add the host to your hosts file:

c:\windows\system32\drivers\etc\hosts

If you are on the server and using a fully qualified domain name, your request will be blocked by the server (loopback security check).

See explanation of this and how to work around it (OBS: dont disable loopback check as some blogs advice you to do).

Read more on Spence Harbars blog.

share|improve this answer
    
oops, just said almost the same in other words and with another link. –  Alexey Krasheninnikov May 4 '10 at 5:35

To create a "site" in SharePoint you need to first create a Web Application, and by the image it looks like you have done just that. Then you have to create a top-level Site Collection for that web application, have you done that?

share|improve this answer
    
yes i did...i create the top level site... –  Anonymous Apr 19 '10 at 10:21
    
top level site is created successfully but when i try to access it in browser it show me that the program can not display the page... –  Anonymous Apr 19 '10 at 10:31

Browsing to the site from IIS may replace the host header name with 'localhost' and Sharepoint wont like that. If you created the site collection with a host header then just enter that in the URL in IE. If you created it with a port number then browse to the machine name + port number.

When in doubt open Central Admin -> application management -> site collections, and select the correct web app / site collection, copy and paste the url into IE.

share|improve this answer

I would double check the Alternate Access Mappings properties for the application in CA. The configured URL needs to be accessible whether you use IP, Servername, or a FQDN.

share|improve this answer

Judging from the screenshot, you are using host headers. Make sure that the nslookup command line utility returns 127.0.0.1 or a valid IP pointing back to your server. As a proactive next step also apply the recommendations regarding the BackConnectionHostNames or DisableLoopbackCheck registry key from the knowledge base article 896861.

share|improve this answer
    
Shouldn't that give an acces denied error if it is the loopbackcheck? –  Koen Vosters May 4 '10 at 8:13
    
Only after the IP is resolved AFAIK. Before that - nope. –  Alexey Krasheninnikov May 6 '10 at 8:59

First things first. Check the windows event log. Go to the run menu and type -> eventvwr.

This could also be related to permissions both at site level and the database level. Let us know your findings.

share|improve this answer

Check the account that the application pool is running under. It's possibly NETWORK SERVICE.

This account probably won't have permissions to create databases on the DB server. If the DB server is on a separate machine, you I don't think you'll be able to do this. The App Pool account context needs to be a domain account that is a member of the IIS_WPG group on the server running IIS. SharePoint should grant this account everything it needs on the SQL Server when you set up your Web App.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.