Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am getting a "The server returned a non-specific error" with a DataView in SPD with SP2010.
The DataView is working fine up to that, i.e. I have added and removed cols, Filtered and Sorted and added Inline editing and all this works corectly in the browser after I save changes. When I then go back into "Sort & Group" and select the Show Group Header option and select OK, The data table collapses down and gives that error ?? The Data Source is a View in SQL server. Any suggestions gratefully received. JK

share|improve this question
    
How many items are in the view in SQL? –  Lori Nov 22 '11 at 15:17
    
Also check the field type - is it having trouble grouping on this type? Start real time logging with the ULS Viewer on the server (archive.msdn.microsoft.com/ULSViewer). Then go into SPD and apply your grouping. Go back to the logs after this and there's a chance you'll at least get a stack trace that'll help you get to the bottom of it. –  Panter Nov 22 '11 at 16:36
    
Thanks for that. Will have a look with ULS. –  JoeK Nov 25 '11 at 9:05
add comment

1 Answer

I've found it easy to recover the page by creating a new form in SPD, then taking the <DataSources> section from the new page and replacing the <DataSources> in the corrupted page. Of course, if you've created special filtering, this would have to be redone. But this is a quick way to recover the page.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.