SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After uploading a form under manage form templates under central admin, i am getting the status as "Upgrading" for a day.. The form is not getting upgraded.

All the application pools are running. Checked the timer and administration service under services.msc, they are also started.

I checked the below link:

But the solution in that did not help.

I also tried this: going to 14 bin in cmd prompt and then running the below command:

stsadm.exe -o execadmsvcjobs

I got the message as: The administration service is running so all administration jobs will be run in the timer service.

How to fix this form template uploading issue?

Thank you

share|improve this question

Open Central Administration and go to Operations/ Timer Job Definitions

Find your form template job and delete it. Then click Manage form templates on Application Management tab. Refresh this page. Probably it shows your form template that it is ready.

I know this is not a real solution, but it saves time ;)

share|improve this answer

If this issue is on a development server, can you try restarting the SharePoint timer job in services.msc? Is this just for one Infopath form or all of them in the farm?

share|improve this answer
It is in dev environment. i have restarted the services. still the same error. It is happening for all forms. – venkatzeus Nov 22 '11 at 11:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.