SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have an installation of SharePoint 2010 in which access to SharePoint designer has been granted within Central Administration, as well as at the site collection level.

Whenever I try to open the site, or any of its sub-sites in SPD, I get an error stating:

"You do not have permission to do this operation. Ask your web site administrator to change your permissions and then try again, or log in with a user account that has this permission. To log on with a different user account click OK."

My user has full control over the site collection and the site itself. I've also tried using the farm admin account, as well as trying on several machines.

I'm currently at a loss. Anyone have any ideas?

Not sure if it matters or not, but this site is setup to be accessed via https only -- don't think that would matter at all, but worth mentioning. I have a redirect for any http traffic. I did revert that to verify I still could not access the site in SPD. Also, I just checked to make sure the site was not set to read-only, and it was not.

Removed and set as an answer below, will mark as the correct answer when it lets me.

share|improve this question
up vote 3 down vote accepted

Just figured this out! Apparently when the web application was setup, it was configured for Claims Based Authentication. Our IIS site was setup to only use Windows authentication. I had to enable Anonymous and Forms authentication on the IIS site and SPD started to work.

I'm not happy about the oddly setup web application so I'll likely end up rebuilding it. Oh, the joys of inheriting projects.

I couldn't set it as the answer because I do not have enough permissions yet. I'll try back later.

share|improve this answer

In central admin, is the use of SharePoint Designer allowed for that web application? It sounds as if it's disabled which is why it would throw that error even when using farm admin creds.

share|improve this answer
SPD is allowed every where, central admin and site collection. I've been messing with various things trying to give it a little kick-start into working. I disabled all SPD settings in central admin and at the site collection, with it disabled SPD errored out with "SharePoint Designer is disabled." I have since re-enabled them all, still no luck. – Jon Nov 19 '11 at 20:56

Verify your WebApplication policy that might be set on that WebApplication which gives you readonly permission. Update it properly and you are done.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.