Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I had been working with a custom content type in one of my development site collections and everything was working fine. I then tried setting the "Site URL" in my project I started getting this error:

Error occurred in deployment step 'Activate Features': The content type with Id 0x010100C568DB52D9D0A14D9B2FDCC96666E9F2007948130EC3DB064584E219954237AF3900242457EFB8B24247815D688C526CD44D00686902DCEDA048E5B29BDA9E09CD73FD defined in feature {9d4762bf-a969-4b05-8110-811e329996ad} was found in the current site collection or in a subsite.

So I switched back to the old "Site URL" and tried to retract but got the error:

Feature '9d4762bf-a969-4b05-8110-811e329996ad' is not activated at this scope.

What would be the proper way to deploy to the new Site URL?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Custom content types thru features can be very finicky... I think you need to ALWAYS retract before re-deploying elsewhere.

As far as your issue goes, I think you can try setting your URL back to the original and re-deploying. Once it deploys successfully, then retract it.

I think you're getting Error #1 because it was installed in the content database already (so the guid exists) even though it isn't activated.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.