Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I uploaded my company's site logo successfully to my site and whenever I created sites under my site collection, the logo is inheriting successfully. But the problem is when I click the site logo from any sub-site, it's taking me to that particular site's homepage, but not to the top-level site. How could I do that?

share|improve this question
add comment

3 Answers 3

The OOTB master page uses the ~site token as the URL to surround the site logo, just change this to ~sitecollection/ (the trailing slash is necessary) or even / depending on your particular requirements.

In v4.master the section to change is at line 297 and should wind up looking something like:

<SharePoint:SPLinkButton runat="server" NavigateUrl="~sitecollection/" id="onetidProjectPropertyTitleGraphic" >
    <SharePoint:SiteLogoImage name="onetidHeadbnnr0" id="onetidHeadbnnr2" LogoImageUrl="/_layouts/images/siteIcon.png" runat="server"/>
</SharePoint:SPLinkButton>
share|improve this answer
add comment

You need to edit the logo URL from SharePoint Designer... No options are available Out of the box...

share|improve this answer
add comment

out of the box, as said it is not possible. However, doing it for all sites separate would be ....... ().

Better to use a little script (JScript) finding the link in the DOM (by name or ID) and replacing it with the required URL.

share|improve this answer
2  
Using javascript for this is not the best approach. SharePoint has a built-in url token system that should be leveraged –  GavinB Nov 17 '11 at 2:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.