Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Using SP2010, I have a list containing a column with rich text (i.e. contains html). I would like to display this column using a content query web part - but when I do, it displays the actual html, rather than the formatted text. Is there a way around this?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

You will probably need to edit the xsl to add a disable-output-escaping attribute.

http://blogs.msdn.com/ben_hickman/archive/2009/05/22/content-query-web-part-example.aspx

share|improve this answer
    
I've attempted to make this change to the "ItemStyle.xsl" in the "Style Library" - however, I'm not seeing the changes picked up in the CQWP. Is this not the correct file to modify? –  Jeremy Apr 16 '10 at 12:54
    
I haven't done this is SP 2010 yet, but I assume its the same as 2007, and yes that should be the right file. Perhaps edit your question to add the change you made and we can check it out. –  Paul Lucas Apr 16 '10 at 14:43
    
Thanks for the feedback. I figured out that I was adding the disable-output-escaping attribute to the wrong xsl template. I was using the one labeled "Title and Description" - this corresponds to the "NoImage" template in ItemStyle.xsl –  Jeremy Jul 23 '10 at 22:22
add comment

Click on the cell, click on the arrow at right top corner of that cell and choose the appropriate format.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.