Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

On any Sharepoint 2010 MySites page there is several links at the top. Upon using a people search in the SharePoint front-end, the search results in the MySites web application. Good, everything looks good from there.

Then the MySites links at the top aren't following the https://foo.domain.com address. It wants to follow http://intranet:port and the same with search results FROM the MySite pages...

Any idea where to change that? Also, I try to "Setup My Sites" under the user profile service application of the front end, and I use the DNS names https://sharepoint2010.domain.com/searchcenter/pages for the preferred search center and https://mysites.domain.com for the mysite host, and when I click ok its almost instant and when I go back to check the settings, they are all reverted back to http://intranet and http://intranet:port instead of my DNS URLs.

Whats the deal?

share|improve this question
    
While your post is tagged with alternate-access-mapping, you make no mention of it within your post. Have you configured alternate access mapping within central admin? –  Paul Lucas Dec 12 '11 at 5:24

2 Answers 2

The My Site Settings page you referenced is the first place to set it. Make sure that it is a valid path to a site collection with the My Site Host. Following your address http://mysites.domain.com/ should have that My Site Host in the root site collection.

The next thing I would do is check your user profile by searching for it within the User Profile Service App in the Manage User Profiles area. If you initially created a site on http://intranet:port it may be set there.

share|improve this answer
    
I still need more ideas. All the URLs are valid and correct. –  Mike Nov 11 '11 at 22:49
    
Anyone have any other ideas? –  Mike Nov 15 '11 at 20:27
up vote 0 down vote accepted

I think this deals with ISA redirects. HTTP(S) Requests are dealt with ISA first, and that makes me believe the problem is the ISA settings...

Sharing port 433, because we have SSL enabled, I had to set up host headers and configure them using SSL, so that IPs on 443 can be differentiated between one sharepoint web application and another web application hosting mysites.

This link shows you more about how to do that: http://www.agileconcepts.com/Blogs/AQ/Lists/Posts/Post.aspx?ID=18

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.